Fly Away Simulation
SearchSearch 

FS9 start Error message: Cannot initialize aircraft

Shalton Guest

I flew the night before without a problem and the next day when I started up I got the Error "cannot initalize aircraft" and it shuts down. It usually has an aircraft after the word initialize such as Cessna 172SP. I have been adding addon aircraft, scenery etc.one at a time and then opening the program to make sure it works. However nothing was added before this happened. I hope some one can help. I'm grounded for now and I hate it. I hope I don't have to reinstall it. Thanks.

Pro Member Chief Captain
RadarMan Chief Captain

This may be it, usualy DirectX but first I would delete the last flight you took, The folder for that is in "My Documents".

http://support.microsoft.com/default.aspx?scid=kb;en-us;837195

As a last resort delete the fs9cgf file and let the sim rebuild it.
http://www.fs2004.com/forums/index.php?showtutorial=14

Radar

Shalton Guest

I tried it all and it still does it. It did go to loading scenery files and then it froze up.

Pro Member Chief Captain
tomthetank Chief Captain

Read Radar mans 1st suggestion is the one that works 9 times out of 10 Ermm... Idea

http://support.microsoft.com/default.aspx?kbid=303032

Try the clean boot and let us know

Also video card, memory and cpu specs may be of some use to us

Shalton Guest

I tried it all but to no avail. I'm running a 1.3 AMD chip, 512 ram, Ati 7000 with all the latest updates. I've been using Flight Sim Manager whenever I can to install addons. My last flight was with a Cessna 172SP so when I went back to FS9 the next day that is when it said "cannot initialize Cessna 172SP aircraft". It had a close button in the box and It closes the program. I repair and build computers for a living so I am not a novice. I am getting gun shy about adding any addons. This happened once before and I did a reinstall and started over. When I did the last error for the aircraft I did not install it. I did install all of Doherty's dangerous landings which I enjoy. I was hoping some one else had this same problem with a solution as it gets old reinstalling.

Pro Member Chief Captain
tomthetank Chief Captain

😕 If you have removed the last flight from the My documents/flight sim files and its still happening,you probably ticked it to be the start flight when fs9 starts.Delete all old flights(copy and paste it somewhere for back up)and try again
Also you could try removing the Cessna 172SP from the aircraft file

Try that and let us kow

Shalton Guest

My Flight sim files folder in my documents was empty. I removed the entire Cessna 172SP folder. Where is the old flights located, are they suposed to be in the my documents file Flight sim files folder? Anyway It still didn't help doing the first two. Even with the Cessna folder gone it still said it could not initialize the Cessna 172SP.

Pro Member Chief Captain
tomthetank Chief Captain

😕 If you ar running XP open up your main disc "C"then look for My Documents and Settings then your user name folder and Flight sim files
Just to see if anythings in there

Shalton Guest

Yes I did look and it is empty.

Guest

Hi Shalton,

the problem is, Cessna 172SP is the default FS aircraft, and Flight Simulator will by default try to load it.. this is one aircraft you should never mess with - I believe from v2.6.1, FlightSim Manager stops removing this aircraft.

If you have a copy from somewhere, I suggest installing it.. otherwise you can also download RealAir's Cessna, and get that to work.

The other option would be to create a default flight file with a different Aircraft - FS should load that aircraft model at startup.

regards
Rana

All times are GMT Page 1 of 1

Related Questions