Fly Away Simulation
SearchSearch 

patch compatibility

tazz Guest

I tried to install the new patch for fs9. A message board came back saying my version of fs 2004 was not compatible with my version. Do I have to by a newer version.How many versions are there.

Pro Member Chief Captain
RadarMan Chief Captain

Go to the MS download site and read everything over carefully. You have to have a new (free) updated FSUIPC and a few other items to run the update.
There is only one version of 2004 so reinstall it and then run the patch.

https://flyawaysimulation.com/downloads/files/2795/flight-simulator-2004-update-v91/#download

https://forum.flyawaysimulation.com/forum/topic/2608/fsuipc/

Radar

All times are GMT Page 1 of 1

Related Questions