Fly Away Simulation
SearchSearch 

ground problems

Guest

I have FS 2004 and a Saitek X45 joystick. My problem is everytime I try to manuver my aircraft on the ground, the rudder sticks to the left. When I'm starting my taxi to the runway, everything seems fine, then all of a sudden the plane makes a hard left turn and I see the rudder just automatically flicks into the left position and stays there unless I straighten it, but it eventually does it again and again. I wasn't sure if this is a common software problem or maybe it's the joystick, but it seemed to me that maybe my computer has a virus or something. Any ideas on how I can stop the rudder from flicking into the left postion while moving on the ground? It doesn't seem to be an issue when the plane is airborne. Thanks.

Pro Member First Officer
Netz Rafi (Rafi) First Officer

Did U rty calibrate it? I hardly belive it is some thing wrong with your JS or U ahve virus

Pro Member Captain
David (The-GPS-Kid) Captain

Hi Guest,

This is a common problem with Saitek Joysticks. Updated drivers are available from the Saitek web-site, and also calibrating your Joystick and turning off "Auto Rudder" helps with this problem.

I didn't have Internet access to download the updated Saitek drivers, so ultimately in that situation it was a case of swapping the Joystick for a Logitech one ! You should be fine if you can get the updated drivers though.

Good luck !

Guest

Thanks for the info. I updated the driver, so I will see what happens. Also, how do you turn off the auto rudder?

All times are GMT Page 1 of 1

Related Questions