Fly Away Simulation
SearchSearch 

Expansion pack MFD problem

Pro Member Trainee
BatmanYZFr1 Trainee

Hey guys. I have searched for threads on this topic and could not find anything helpful. The new aircraft in the expansion have no MFDs or HUD's. I have reinstalled several times with my security setting off and on. I've tried the repair function as well and still nothing. The aircraft fly perfectly. Just at engine start up the instruments dont fire up. please help!!!

Pro Member Trainee
BatmanYZFr1 Trainee

jeez...90+ views and no one can help with this. Am the only one? maybe it's just a click of the right button in the cockpit...i dont know. like i said, the instruments dont fire up on engine start. desperate here, dont wanna discard the expansion cause of the potential Crying or Very sad

Pro Member Chief Captain
Tailhook Chief Captain

If by "Expansion Pack" you are referring to "Acceleration" I am not surprised Google came up with a blank.

If I'm all together wrong, pray tell kind Sir, would you have a link to that Expansion Pack?

Pro Member Trainee
BatmanYZFr1 Trainee

Tailhook!!! nice to hear from u again 🍻
I wanted to thank u for ur help with my repaints from back in the day. Ur assistance was stellar.
Back to my current problem, yup its the acceleration pack. I actually bought the FSX Gold edition just to get the expansion pack, no link. What sucks is that my brother and I got them at the same time, same store. We both just installed the Acceleration disc on top of our FSX deluxe. His is flawless and mine, as i said, give no HUD or MFD on engine start up.

help help help!!! Help!

Pro Member Chief Captain
Tailhook Chief Captain

Sorry, your name had slipped my mind, it's been a while.

Now, I'm afraid I won't be of much help here. Here's the low-down. I got Acceleration purely for the purpose of being able to use Dino Cattaneo's Goshawk and F-14 and Xavier Fernandez's Nimitz.
I did fly the carrier missions using the included F-18 and the Helicopter missions where you have to fly through hoops and did at that time not notice ANY missing MFDs or HUDs. Since then I haven't used Acceleration or selected any of the included a/c. (Acceleration is off course required to use many of the now freely available add-ons).
In an attempt to recreate your problem and look for the missing gauges I loaded FSX but alas now I can't find the Accel. a/c OR the missions in the menu. Accel. obviously still works as I have no problems going wild with Dino's a/c or Xavier's Nimitz (this actually includes other 3rd party freeware COP a/c) ...but selecting Accel. a/c has turned into a quest that seems to lead to nowhere.

BatmanYZFr1 wrote:

.. installed the Acceleration disc on top of our FSX deluxe. His is flawless and mine, as i said, give no HUD or MFD on engine start up.

One thing which might be more than useless information: I installed Accel. after UTX-USA which screwed up my scenery.
I have read that uninstalling and then reinstalling UTX will solve the problem (haven't gotten around doing this yet) - the logic being the proverbial brick upon brick i.e. Acceleration first, the rest later.

There's a possibility that you're friend's install hadn't included any add-ons that could have messed with his set-up. It's worth a thought 🤔

Back in FS2004 days when SP1 was released, we were told that SP1 could interfere (which it did) with 3rd party add-ons. The remedy was to get rid of all add-ons, install SP1, reinstall the add-ons and the problems were solved.

If my memory serves me, prior to Acc. we had SP1 and SP2 for FSX. Concerning one or both of those SPs the same principle applied. Logic would dictate that this is also true regarding Accel. If in doubt, visit one of those "FSX Insider" sites... you'll probably get a clue there.

I'm sure you'll solve this anomaly one way or another and I have a hunch it won't be a major operation. Sharing your discoveries with us will of course be much appreciated. 🍻

Pro Member Trainee
BatmanYZFr1 Trainee

Well I just got off the phone with MS. 1st I will say that their tech staff were nice and courteous, but we did not get far. They were sticking with the problem being with the 2D cockpit and were telling me to use the 3D. (It's the 3D cockpit that I am having the problem with, true the 2D doesn't work but I can live without it. ) They said that a 2D cockpit fix or patch is coming and that the 3D problems occur in some machines and not others and they just can't put their finger on it.

We then went into the DXdiag, tech advised that I had plenty of power so just to wiat for the fix. I cant sit idle like that, especially after paying for FSX twice (deluxe then the gold just to get the Accel pack)

There's a possibility that you're friend's install hadn't included any add-ons that could have messed with his set-up. It's worth a thought

I have, absolutely, signifigantly more add-ons to my FSX than he does, so I am going to go the route of pulling them off and re-install. All these "bricks" Wall Bashing

Like ya said, its worth a thought.
I'll let ya know

Pro Member Chief Captain
Tailhook Chief Captain

BatmanYZFr1 wrote:

...I will say that their tech staff were nice and courteous, but we did not get far...

This is what I call: "Standard Microsoft Remote Controlled Tech Support" -- (patent pending).

...the 3D problems occur in some machines and not others and they just can't put their finger on it.

WHAT??? As of now I'm changing my religion. The golden Microsoft idols and gods are being melted down as we speak.
Makes you wonder what they needed an "Aces" team for in the first place. So, you're supposed to just sit there and wait for the fix... what a cheek Evil or Very Mad What's taking them so long?

My outburst won't solve your problem but at least be assured that some of us are disgusted with Microsoft's arrogance and incompetence.

I still haven't found the time to uninstall and reinstall UTX-USA per my previous post as I'm spending most of my time with FS9. Once I've done that I will inform you of the result too.

Pro Member Chief Captain
Tailhook Chief Captain

Well, I've done it and I have EVIDENCE 😀

This is what it looks like when Acceleration is installed on top of UTX
...somewhere near San Diego

(Oh yeah, that's my private yacht there stranded in the desert.)

Having uninstalled UTX gives us this picture:

(My yacht's afloat again - let the Champagne flow 😛 )

The following two pics show the same area after having reinstalled UTX:

(My yacht can be seen in the distance.)

NOTE: The inferior quality of the terrain/ground textures in the last two pics is due to the fact that I haven't tweaked any of the UTX features yet.
I merely wanted to illustrate that installing certain add-ons in the wrong order WILL create havoc.

Batman in your case since HUDs and MFDs are concerned, I'm speculating that uninstalling aircraft might fix the problem, in particular payware a/c or others which use a self-installer.

I keep my fingers crossed. 😀

Pro Member Trainee
BatmanYZFr1 Trainee

Tweaks or no tweeks I difference is obvious, nice job.
Well my friend, I have had success!!!!! Group Wave you may uncross your fingers. thanks 😂

I cant believe that Microsoft's Tech said they did not know about this fix and I should wait for one to come. The worst part is that I saw that this has been an issue sine DEC '07. (they should have known!!!) Doh!

Anyway...I followed a lot of links to several FS forums (ironicly the final fix tip lead me back here to a post from 2007-2008 by a Skorp...(cant remember the proper spelling of the screen name. Many guys had their own fixes: form complete uninstall (caches, registries, anything that had anything to do with FSX had to go ) and then a reinstall with rebooting between each SP and the FSXa pack. Others just played with windows files.

Either way it came down to the SIMCONNECT.DLL issues - I took bits of advise from a few guys. here's what I did:

uninstalled FSX accel

then I backed up and removed the Simconnect.dll
file in windows/winsxs / x86 microsoft flightsimultor...

I then did a defrag of the hard drive.

reinstalled FSX Accel

Reboot before activating.

I checked the Simconnect files and the reinstall rewrote them without any
prompt from me for the old ones.

activate FSXa and boo-yah!!!! HUD and MFDs function in both my f-18 and the heli (big coast guard one -forgot the model)Again, this is a recipe from several different guys. The all seemed to have success. I took the bits that appealed to me (short cuts really ) and put them together and it worked.

Thanks again Tailhook for ur insight 🍻

Pro Member Chief Captain
Tailhook Chief Captain

Well this calls for celebrations

Now believe it or not, many moons ago I recall reading something about a possible conflict with a particular version of FSUIPC and SimConnect. I quickly put it out of my mind living under the delusion that I had nothing to do with SimConnect 😳

Just did a search and found that I DO have no less than 3 SimConnect.dll files exactly where you said they would be. So far so good -- but now of course I wanted to know what the hubbub is all about and what those seemingly important .dlls are supposed to be doing.

HA...!!! Just looking at the first two "FSInsider" pages gave me the shivers:

About SimConnect

1/19/2007

Over the years, the Flight Simulator core code has seen significant restructuring, and in the process the legacy Flight Simulator drop-in module system that for many years was used to programmatically retrieve data and send events has become defunct. This might have been a serious problem for our developer community because of the large number of third-party Flight Simulator data access tools that use the legacy module system. Our priority was to ensure that the strong third-party community continues to thrive, and so we needed a solution that provides similar functionality. That solution is SimConnect, a flexible, powerful, and robust client-server communications protocol allowing asynchronous access to data and events internal to Flight Simulator X.

SimConnect is based on a client-server architecture that incorporates a Winsock communications protocol to allow third-party client applications to communicate with the internal Flight Simulator server. ---

The mode of communication is considered asynchronous, which provides some advantages over the use of synchronous communications, for instance communication in applications such as FSUIPC.

Asynchronous communications:

* Are safe for use in multi-processor or multi-threaded applications
* Use processing cycles more efficiently
* Provide greater server application stability

While latency in closed-loop systems provides one potential drawback to this method, this can be overcome through proper code architecture of client applications. Please take care when developing add-ons that rely on a closed-loop architecture, such as autopilots or AI controllers. [blah, blah, blah...]

If you feel inclined to read the complete chapter of techno-babble, knock yourself out ==>> http://www.fsinsider.com/developers/Pages/AboutSimConnect.aspx --- but you see, I did find a reference to FSUIPC

Phew, don't know about you, but I find it easier to make sense out of Dr. Sheldon Cooper's in depth explanations of the functioning of the universe than this FSInsider drivel.

Go Sheldon go!! Sheldon for CEO of Microsoft!!

Here's more:

Support Alert: Do not delete SimConnect.dll

2/8/2007

It has come to our attention that some FSX customers are experiencing intermittent problems with add-ons not working when using the SimConnect interface. This might be seen through the loss of add-ons appearing in the Add-on menu or the obvious discontinuity of functionality between the add-on and FSX.

We are actively looking at this problem, and have tracked it down to a NT_STATUS_CONNECTION_RESET in the low level connection layer of the Operating System.

Although we do not yet have a solution for this problem...

More here==>> http://www.fsinsider.com/tips/Pages/SA0001.aspx

As you said: 2007

I'd better shut up now lest Microsoft hit me with a libel case.

Happy flying Batman, if you find yourself in a tight spot, you can always unfold those wings of yours 🍻

Pro Member Trainee
BatmanYZFr1 Trainee

ROFL I can only laugh now after that torture. I read the quotes and I guess, in short, microsoft just cant "officially" say to delete those SIMCONNECT.DLL files and start over. I dont want to say too much either...no doubt Billy G has a group of those intel radar blow dart ninja assasins that would come after us. No, No!

Brother thanks again (though u sadly dont remember the repaint help [and u put some overtime into it, believe me] you gave me from a year or so ago. But thats a good sign, T hook is out helping number of wayward pilots find their way. 😉

My wings are unfolded and I SOAR!!!!!!

All times are GMT Page 1 of 1

Related Questions