SearchSearch 

Performance issues

Pro Member Trainee
MaXimusMyth Trainee

Greetings,

I've noticed, expectedly, that FS9 gets jittery for me and experiences frame rate drops from time to time, particularly near cities and airports (I'm running on an old machine with an old card...512 Ram, GeForce 3).

What I'm wondering, is what the best options are in terms of tweaking, that will provide me with the best performance. E.g. would it be more beneficial to drop the autogen density, clouds, global detail, etc.?

Secondly, does adjustment of the framerate make a major impact? I currently have mine at 30fps.

Thanks

11 Responses

Pro Member Captain
Jared Captain

Well to me 30 FPS wouldn't be too bad. But I have the the scenery turned to medium or high. There is a ox that you can select perselected secenery configurations. I lock my FPS at 35 and it be hitting 35.

Pro Member Chief Captain
RadarMan Chief Captain

Try using this program to shut down most of the programs running in the background before you start to fly.
See what a difference it makes.

http://library.avsim.net/search.php?SearchTerm=speedup_152206.zip&CatID=fs2004util&Go=Search&Cookie=1

Radar

Pro Member First Officer
SoCalRick First Officer

MaXimusMyth wrote:

What I'm wondering, is what the best options are in terms of tweaking, that will provide me with the best performance. E.g. would it be more beneficial to drop the autogen density, clouds, global detail, etc.?

Clouds, traffic, and water effects are big FPS eaters. I'd recommend zeroing those out until you get smooth performance, then bring them back up one at a time until you have a satisfactory combination of quality and performance.

Also check your video card settings (right-click your desktop, click Properties, Click the Settings tab, Click the Advanced button, find the tab for your video card and click it), to see what antialiasing and antroscopic filtering settings you have. Note them and reduce to OFF or Application Controlled for now. You can come back and tweak up to reduce jaggies and get clearer distant views after you solve the current problem.

Go to your hardware tab in the Settings>Display>Hardware tab in the sim. You should uncheck Antialiasing if checked (this should be handled buy your graphics card, not FS9). Set Bilinear Filtering, then MIP-Mapping to 4. There's another slider directly beneath MIP-mapping, I can't recall the name right now, but set its value to 5 or 6 max.

MaXimusMyth wrote:

Secondly, does adjustment of the framerate make a major impact? I currently have mine at 30fps.

It does make an impact because the higher you lock the rate the more CPU overhead FPS takes, whereas if you make this lower you'll get smoother performance. The best compromise is 18-20 for your hardware, but if you add another 512MB RAM I'd bump it up to 25. If you go over 25 you'll hardly be able to see a visible difference.

Pro Member Trainee
MaXimusMyth Trainee

Thanks for the advice gentlemen, I'll try and experiment.

The problems I'm experiencing don't seem to be typical framerate issues, however, as I've begun to notice. Performance will be smooth for anywhere between 20-40 seconds, followed by about 3 seconds of sluggish behaviour. It doesn't seem like much, but A) it's infinitely bloody annoying, and B) can cause a fatal screw up when it happens during final approach (which it always does).

I could understand it happening during certain points like this if the graphic detail was heightening progressively (such as, on an approach), but not during normal flight, etc.

...Need a new computer.

Pro Member Trainee
MaXimusMyth Trainee

It seems odd. After lowering several settings and witnessing a blatantly visible drop in graphic quality...it still goes jittery in increments, same as before. Perhaps something else is going on.

Pro Member First Officer
SoCalRick First Officer

MaXimusMyth wrote:

It seems odd. After lowering several settings and witnessing a blatantly visible drop in graphic quality...it still goes jittery in increments, same as before. Perhaps something else is going on.

Yep, scenery stutters have many possible causes so you have to experiment until you find the answer.

Click START>RUN and type %appdata%\Microsoft\FS9 to find your fs9.cfg file, then rename it to fs9.cfgBAK and once again run the sim so that FS2004 can automatically build a new configuration file. If the problem persists, you can go back to that directory, delete the new fs9.cfg and rename fs9.cfgBAK to reinstate your previous state.

Also, have you checked for new video drivers recently?

Pro Member Trainee
MaXimusMyth Trainee

I don't believe so. What's up with them?

Pro Member First Officer
SoCalRick First Officer

MaXimusMyth wrote:

I don't believe so. What's up with them?

Upgrading drivers can often fix hard-to-troubleshoot video-related problems, so it's a good place to start. If there is any problem caused by the new drivers it's simple to roll back to the previous ones.

Did you try letting FS rebuild the fs9.cfg yet?

One other thing: are your sound settings on low, medium, or high quality in the sim? Believe it or not this can be a source of trouble in older systems, so go with LOW sound quality for now.

Also in the same vein: Click START>RUN and type dxdiag. When it has finished loading, click on the Sound tab. Set Acceleration to "Basic acceleration" then exit.

Pro Member Trainee
MaXimusMyth Trainee

The only attempts I've made so far have related to altering in-game settings. I'm not too computer saavy, so I'm not entirely sure how to go about updating drivers/returning to previous ones. I'll take a stab at the sound as well.

guest Guest

http://www.outertech.com//?_charisma_page=products Try Cacheman. There are 2 versions. One for WinXP and newer OSs, and one for Win 95/98. Tweaking the cache on my machine, with only 256Ram, got my frame rate up about 10fps...from 14 to now at 24.

Read the details of the cacheman and decide if your computer could use it. It's simple to use. Good luck

guest Guest

guest wrote:

http://www.outertech.com//?_charisma_page=products Try Cacheman. There are 2 versions. One for WinXP and newer OSs, and one for Win 95/98. Tweaking the cache on my machine, with only 256Ram, got my frame rate up about 10fps...from 14 to now at 24.

Read the details of the cacheman and decide if your computer could use it. It's simple to use. Good luck

I just wanted to add one more link. This link will explain a little more about your OS's Cache. http://thpc.info/ram/vcache98.html

What the heck, here's more cache info. http://kpush.tripod.com/tweaking/id5.html

Do a web search for vcache. I found out that the jittery condition was probably due to low Ram available. A couple of tweaks and a little fine tuning and I get over 20fps with lots of eye candy and lots of detailed clouds. And no JITTERS. I hope this can help others trying to get the stutter or stuttering out of their air space. Good luck.

PS. if you are able to adjust your Sys.ini file you can try changing the minvcache and the maxvcache settings to 65536 if you have 256 of RAM. Anyway it's covered in the links above.

All times are GMT Page 1 of 1

Related Questions