Fly Away Simulation
SearchSearch 

My PC's DVD drive just chatters away trying to install FSX!

Robert Crowther Guest

I know my set of FSX Gold disks are perfect, clean and OK for Windows10.

They also install without any issue on other laptops Iíve tried, including half a dozen on the shelf at PC World etc! Also, a/v (Panda and Malwarebytes) was disengaged during all attempted installs.

It's just my PC - Disk 1 goes in and then chatters away for at least 90+ minutes before reading enough to start installation. Same with Disk 2 and likewise the third, Acceleration disk. I've tried changing physical drive hardware, updated/reinstalled DVD drivers, also tried plug-in drives, plus increased the power supply from 600W to 750W.

Sometimes, the change works at the first attempt Ö but then always reverts back to the same old problem.
If I wait long enough (90+ mins) the chatter usually stops (Disk1, but not on inserting Disk 2 or the Acceleration disk). I can start an installation from here, but end up with the error code: 1-80004005 which I guess is an activation problem with the Acceleration install that Iíll have to see if I can resolve.

Is it some conflict arising between drivers loaded somewhere in my PC and the write-protect of the install disks?

If so, why doesnít the same issue happen with other programs? Am I really the only one to have ever experienced this problem?

Itís soooo very, very frustrating, not least getting brief glimpses of what I should be able to run.

Any ideas what I can do to solve this would be really welcome please!!

All times are GMT Page 1 of 1

Related Questions