Fly Away Simulation
SearchSearch 

Windows 7 Professional 64 bit Flight Simulator X crashing

TheFlyingPolak Guest

I have a frustrating problem with my game. When I'm playing and I press esc to bring up the menu, it doesn't come up and instead the screen stays black, the loading cursor is on and eventually the game crashes, with a message saying "A fatal error occured" and nothing else. After every crash any settings I changed in the game (graphics, controls, etc.) went back to default.The game worked fine on windows 7 home premium 32 bit. The problem is happening ever since I switched to professional 64 bit.

I tried changing compatibility mode of the game a few times. I tried patching the game to SP1 and SP2. I tried the method with putting in uiautomationcore.dll. Nothing worked.

Please help guys Crying or Very sad

PC stats:
CPU Intel Core i5 3.2 GHz
Graphics ATI Radeon HD 5800
8 GB RAM
Windows 7 Professional x64

Pro Member Chief Captain
RadarMan Chief Captain

I can think of two possibilities.
1-It's one of your add-ons, possibly a AI traffic add-on.
2-Many have had problems when adding SP2.
The best way I have found to add SP1 and SP2 (both needed) is by a fresh install of FSX and adding The Acceleration Pack which contains SP1 and SP2, they seem to enter the Sim without any problems.

Let us know how whatever you choose help.

Radar

TheFlyingPolak Guest

1- I do not have any addons installed.
2- The problem is happening with a fresh install and with any patch

Pro Member Chief Captain
RadarMan Chief Captain

Try lowering some of your memory eating slides such as autogen, shadows, clouds and AI.
For a last resort delete SP2 and see how it works.

Radar

TheFlyingPolak Guest

I lowered clouds to an absolute minimum and I completely disabled scenery autogen, all AI traffic and shadows. I also did it again after I uninstalled SP2. Still not working

Pro Member Chief Captain
RadarMan Chief Captain

When is the last time you cleaned the dust out of your computer.
Blew the CPU and other fans clean.
Reseated all your ram and cards.
The machine needs occasional attention or it crashes when pushed to it limit (overheating)
If you don't know how just ask, and I or someone else will be more than happy to help.

Your problem is very baffling.

Radar

TheFlyingPolak Guest

I cleaned all dust out of my computer last week.

I am suspecting that this is rather some absolutely weird problem with the machine trying to open in-game menus (no idea why could that be), not crashing due to overworking.

There have been extremely rare occasions where the pause menu did indeed open and I could close the game as normal without crashing and losing all my settings. I don't know how that happened, it was a miracle.

Every other game and program works perfectly on my computer. Only fsx behaves unusually running on 64 bit windows 7.

Is there any chance that my machine is not fully compatible with Windows 7 Professional 64 bit? If yes, how can I check that?

Thank you for your attention Smile It is indeed an extremely baffling, unusual problem

Pro Member Chief Captain
RadarMan Chief Captain

It is, check here.

http://windows.microsoft.com/en-us/windows/32-bit-and-64-bit-windows#1TC=windows-7

How about cleaning out and changing your video card drivers.
Try the latest, if that doesn't do it try the one before what you are using now.

To check the driver number, go to start/search and type in "DXDIAG" without the quotes and you can read your system there.

Radar

Pro Member First Officer
lionlicker First Officer

When you rightmouseclick on the desktop FSX shortcut icon, a popup list should appear with options like [Troubleshoot Compatibility] and [Run with graphics processor..]. Go through all those tests and trials.
I found unchecking the Preview DirictX 10 option helped. Mine only crashes occaisionally now.

TheFlyingPolak Guest

I found and downloaded the latest beta driver for my graphics card. I ran the game 3 times and it looks like the problem is GONE Shocked Shocked

It's been soooo soooo long since the problem started and prevened me from playing for so long

Thank you so much man Very Happy

Pro Member Chief Captain
RadarMan Chief Captain

Thumbs Up! It took a while but you did it and I'm delighted.
Have fun!

Radar

All times are GMT Page 1 of 1

Related Questions