FSX Not Responding


Hi I got FSX for Christmas and it was working fine. Then one day I go to start it up and I get the screen before it goes into the game and it like wont load. I press CTRl+ALT+Delate and it says that FSX is NOT RESPONDING Could anyone help me out with this problem

Answers 14 Answers

Jump to latest
Pro Member First Officer
faust1200 First Officer

It sounds like a corrupt logbook file. What you describe is exactly what happens when it gets corrupt. Find the program FSX log and you may be able to repair it. Or you can remove the logbook file alltogether and start over.

The file called Logbook should be in the following path: documents and settings/yourusername/my documents/flight simulator x files


I had the same problem. I removed the logbook file from the directory, and it solved the problem. I suspect the logbook file was corrupted when I quit FSX by using the "Exit" <CTRL+C> option from the menu available inside the flight screen, and not "End Flight" <ESC>, as I always do. It's the only time to date I've quit this way, and I only had the problem after doing so.

Thanks faust1200 for the solution!


This also solved my problem.
I've been struggling with on my brothers computer for a week now.

Thank you, thank you thank you very much faust1200 .
😀 <-------- over joyed

Pro Member Trainee
artwizz Trainee

Thanks for the tip on deleting the logbook. 😀


i got fsx and when i try opening it it wont work can some one help me

Pro Member Trainee
naflod Trainee

I had this problem as well. After deleting my logbook and 500+ logged hours I discovered this very website has a recovery file. Find it here:


As for my logbook, I had a backup and was able to recover all but 20 hours of my logged time using this recovery file!

Explore this website, folks! There's hidden treasures EVERYWHERE!!!


Hello, I think my logbook is corrupted also. But for some reason when i go to delete it, It says "This file is in use" and then it says its in use under "System" Please HELP!

Pro Member Chief Captain
RadarMan Chief Captain

Anonymous wrote:

Hello, I think my logbook is corrupted also. But for some reason when i go to delete it, It says "This file is in use" and then it says its in use under "System" Please HELP!

Reboot the machine then you should be able to delete it.


Pro Member Trainee
Carlin Trainee

Guest wrote:

Hello, I think my logbook is corrupted also.

Try FSX logbook recovery.


that wont work, i just tried it, anything else??

Guest Guest

thank u thank u thank u so much faust..🙂 ur the man...🙂 it worked after deleting the damn logbook.. all my approaches were put to a hold for lyk 10days bro.. thnkx..owe u..🙂


i went to delete the logbook file in fsx files but its not there


It sounds like a corrupt logbook I had that same problem.

fsxman Guest

faust and naflod ur THE BEST !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! 😀
I hav fsx, it worked fine for 800+ hours but then I tried to start it and its said not responding. I tried everything I knew to do: restart, system restore, I even let it try to load for about an hour; but still didn't work. then I went to the site naflod said to and down loaded the logbook recovery system thingy. FSX WORKED PERFECT, still have my hours, this is awesome

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...