Fly Away Simulation
SearchSearch 

visual c++ runtime error in fsx multiplayer

damien-arr Guest

several times an evening i get a microsoft visual c++ runtime error "6025: pure virtual call" when flying in fsx multiplayer mode.

what the hell is this random error that freezes up my fsx in multiplayer mode? it occurs at random, and with both addon and fsx stock aircraft. it occurs 30 seconds into a session or three hours. it comes whether i am in another session or hosting my own.

running fsx deluxe w/ SP1 on 3g processor, 2g RAM, Radeon X850 Platinum 256 video.

Pro Member Trainee
Sven2157 Trainee

Hi Damien,

SV2157, from Chicago Flights Server here, I get the same thing constanly. As you said, it could be 30 seconds in, or several hours later, and I even get it a bunch of times in a row, or not at all for the day.

It is very maddening! Evil or Very Mad

I have talked to several people about this error, and apparently it has something to do with GameSpy and the way Microsoft has configured the Multi-Player files.

Unfortunately, I have been looking for a fix for about 2 weeks now, and been unsuccessful at everything I have tried or been told to do. Just keep reporting it back to Microsoft, and hopefully they will release a SP2 Package soon, that addresses this, as well as other Multi-Player issues for FSX. 😕

Good luck, and if you find a fix please, come to my server, PM me here, or shoot me an email at ChiTwnFSX@gmail.com. Thanks man...

Happy Landings.....

Pro Member Trainee
Sven2157 Trainee

I was still looking for a solution to the C++ Error, as well as a solution to the Ban Player Option not being available for use. I went to FSInsider.com and found a link to email the developers at Microsoft Games (Tell_FS@microsoft.com).

Here is the letter I wrote to them:

"Hi Folks,

I have a very serious problem with my Flight Simulator X. When I run FSX in Multi-Player, I get a, “Visual C++ Runtime Error – pure virtual call – 6025”, error, and then the game shuts down completely. This occurs sometimes in the first 30 seconds, or several hours into a session. Sometimes it happens several times in a row, or not at all for the day. In other words… it is random.

I also have SP1 for FSX, and was wondering why I can not BAN trouble makers from my server? I can kick them and I see the, “add player to ban list”, but can not select this option.

I have searched just about the entire web looking for a solution to these two issues, uninstalled Visual Studio, Updated VS, D/L’d VS SP’s, and even reinstalled FSX several times. To no avail, NOTHING works! I can only find people with the same problem in all the Sim forums. There is no support at Microsoft, MSDN, or Microsoft Games, either.

Could you please direct me to a solution for these problems? I am running a server, and it is full for about 5-7 hours a day! I am afraid that people will stop joining because the server resets every so often; which is very frustrating when leaving a busy airport (i.e. waiting your turn to taxi, then take off) to get 20nm from the airport and get booted.

Thank you,

Sven2157"

As soon as I hear back from someone, if I even do, I will post here and let every one know what they said.

Meanwhile,if someone finds a solution first, PLEASE let me know...

Thanks,

Sven2157

Damien-ARR Guest

Are you guys running fsx on vista? I am wondering if it is a vista related issue, as there are a crap ton of those. The administrator priviledges are a royal Minuteman Missle up the ass in Vista. Nothing runs right unless you go in and manually tinker with the administrator and compatibility settings. Even winzip won't run correctly in Vista. Anti-virus software, spyware, adobe apps... I have had problems installing and running just about anything you can think of. Always, so far, found settings and options to get around it- except for fsx.

I blew it off originally since fsx is supposed to designed to run specifically on Vista, you wouldn't think that would be a problem. But Vista sucks as much as fsx so who knows which one blows more?

I just got booted five times in a row trying to join different sessions. This time always within one minute of loading. Been here one hour trying to get in a session and fly. This is ms bs.

Before that, I have been flying in different sessions for hours this evening without a problem.

Have rebooted computer several times and reloaded fsx to no avail.

Had to buy a new computer just to run f#%@ing fsx worth a sh#t and now still can't play the game worth a sh#t.

Bill Gates is the antichrist.

Damien-arr Guest

how are the guys at sigameit.com and bostonvirtualatc.com keeping their sessions up? Why do they not get the visual c++ error that kills our sessions? What's up with that?newsec01

Dalex64 Guest

I was having this problem. I found a solution on the net that nearly applied to this situation, and it worked!

In the ATI Catalyst Control Panel, (for v7.4 and 7.5 at least) DISABLE CATALYST AI in the 3D section.

Pro Member Trainee
Sven2157 Trainee

REALLY! I will try it now..............

GOOD GRATIOUS!!!!!!!!!!!!!!!! THANK YOU IF THIS WORKS!!!!!!!!!!!!!!

Pro Member Trainee
Sven2157 Trainee

DUDE!!!!!! if this works I owe you 12 BEERS!!!!!!!!!!!!!!!!!!!!!!!!!

Dalex64 Guest

Did it work?

damien-13n Guest

I made the change lst night... disabled AI in ATI Catalyst. Flew two hours last night with no problems. So far tonight after couple of hours no problems.

You're fix may have worked. Only time will tell. It is random so it might just be a fluke that I haven't had one yet. Will post again in a couple of days.

THANKS!!!!!!!!!

guest Guest

hello can anybody help me

if i start fsx multiplayer than can i not log in

there stands then 'the network was unable to connect"

what must do I

I have tried 100 time

help help

greats maikel

damien-13n Guest

I hit two runtime errors today. I'm not sure if changing the ati settings made it occur less frequently or not, but it obviously did not provide the miracle fix we're looking for.

NETWORK UNABLE TO CONNECT... it's your antivirus and firewall settings. You need to manually set your virus software/firewall both to allow fsx.exe and port access.

Once you get those settings right you shouldn't have any problem connecting.

guest Guest

Are you using Vista or XP sp1? You can thank Bill Gates for making it virtually impossible for the average person to operate this stuff. Windows has become increasingly user unfriendly, esp the newest Vista. The only good stuff about Vista are all the things ms stole from all the other companies that had good ideas.

Guest

Hi everyone,

I've been encountering issues working ATC in the multiplayer environment - this issues have only arisen post-SP1 installation. Specifically, my radar screen will freeze for 10-15 seconds. After about 45 minutes of session play, FSX freezes and requires reboot. I've talked with fellow controllers and we share two things: 1) we all have SP1; 2) we all experience the same freezing. Any ideas?

I am one of the founders of the >>BostonLoganATC<< multiplayer server. Our server does not have SP1 installed (we tried installing it but our pilots reported frequent problems so we uninstalled it). Reference your question on how we keep our server up without the C++ error, I'm assuming not having SP1 makes all the difference. Hope that helps answer your question.

damien-13N Guest

Then perhaps SP1 it is. I tried the ATI fix and no go. Started multiplayer tonight and the first thing I got was that stupid error and had to restart.

Thanks BostonATC for the info.newsec01

Pro Member Trainee
Sven2157 Trainee

Dalex64 wrote:

Did it work?

It did for about three days.....

and then BAM!!!! Crying or Very sad

Though, it seems to last longer between happenings, then when it starts doing it agin, it hapens like 5 times in a row, in a very short time...

I still have my subissions into the developers, unfortunately with no response yet....

I'll keep you posted.........

Pro Member Trainee
Sven2157 Trainee

Hi Guys,

This error is caused mainly by BAD progamming of 3rd party aircraft; generally gauge DLLS. What is happening is that the "custom" instrument gauge(s), was/were not properly coded and/or compiled correctly, and C++ is making a call to find some instruction that is not there. You can read more about this C++ error at Microsoft - here

This error can be fixed in FSX, by UNINSTALLING 3rd party aircraft.

In order to be successful at this fix, you must make a note of ALL the files installed by EACH aircraft. I find it easier to unzip the files to a New Folder and then go into my FSX folder and locate each one. Then delete them all.

In other words, try to remember when you started getting the error, then uninstall ALL the aircraft that you have installed prior and since then. Or you can start uninstalling aircraft, in reverse, untill the error stops. Once you have COMPLETELY uninstalled these airplanes, one by one reinstall them untill you get the error again. There you go, you found the one that is causing the problems!

One thing I like to do, as I am sort-of a plane junkie, is I create an installer; using the Click-Team: Install Creator, which is a free download. This Wizard powered creator will also give you the option to create an UNINSTALLER. This will then give you a QUICk and easy way to get ALL bad files out at one time.

Good Luck

Sven2157 (SV2157)

All times are GMT Page 1 of 1

Related Questions