Missing Menu Bar!

Pro Member Trainee
mickwill Trainee

Hi All,

I have just got around to moving FSX to my new number cruncher (Intel Quad 2.6GHZ, nVidia 9600GSO 768MB, 4GB Ram). So I installed from the DVD's, Service Packed up to SP2 and I now have a really wiered problem.

1) Holding ALT to bring down the menu bar results in an invisible menu! I usuallly run with the Frame Rate monitor (CTRL-Z) on and when you hold down ALT is shifts down as though the menu bar is there!

2) Right Click on any window does not work - again bizzare!

This is with the default aircraft. I also have installed Ulitmate Traffic and FSPassengers-X. I am running at 1024x768x16 but also get the same result from 32bit modes. I have also downloaded the latetest nVidia drivers to no avail.

Anyone got a clue as to what's going on?


Frustrated of Manchester

Answers 9 Answers

Jump to latest
Pro Member First Officer
oldsamer First Officer

this is new...

Are you running Vista OS ?

Pro Member Trainee
mickwill Trainee

Hi Oldsamer,

Yes, I should have put that in. It's Vista Ultimate SP1 fully patched. All my other programs and games (GTA IV etc) all run fine and the mouse works as expected.

I have just re-installed all the FSX Fonts just in case it is a font problem but still no joy!

Pro Member Chief Captain
RadarMan Chief Captain

Try hitting Alt+Enter, then hit Alt.


Pro Member Trainee
mickwill Trainee

Hi Guys,

Right, I have deleted the FSX.CFG and allowed FSX to rebuild the config file. The menu is now back.

Once small children are in bed I will be doing a line by line comparison to see if I can figure out what was causing this and putting my tweaks back in Evil or Very Mad

It runs very nicely with affinity set to three cores (have to leave one for windows) and apparently FSX will scale to 64 cores!!!



Pro Member Chief Captain
RadarMan Chief Captain

Glad you fixed it.
SP2 if loaded after SP1 or if you loaded the Acceleration pack will activate the usage of all cores, before SP2 they didn't work.


Tigerbeast11 Guest

I have this same exact problem and I can't seem to find fsx.cfg from the directory so I can't delete it. Found the fix yet?

Tigerbeast11 Guest

Found it yet? Please help, I'm really need it!

Pro Member Chief Captain
Tailhook Chief Captain

Informing us which OS you're running i.e. XP, Vista or W7 would be helpful.

GuestFTW Guest

go to your user and go to appdata click on roaming than microsoft then fsx and it should be in there.

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...