"Flight Simulator X has stopped working" problem

Jacob_N Guest


So I rebooted FSX after about a year of not loading it. It was still installed and the last time I used it, the game ran fine.

But now when I click the icon, the 'splash screen' doesn't appear, instead a box appears saying "Flight Simulator X" has stopped working.

Believe me when I say this, I have tried EVERYTHING possible which I could search for. Then as a last resort (or so I thought), I attempted to re-install FSX. Upon installation half way through it crashed with the same message "FSX has stopped working".

This has left me with no ideas.

FYI, I do not have acceleration installed, I run on windows vista, and after viewing the Event Viewer it appears there is a problem with a module called "loadLib interceptor.dll_unloaded"

I couldn't find much on the internet regarding this file.

I'd greatly appreciate any help because right now my only option appears to be a new computer.

Answers 7 Answers

Jump to latest
Pro Member Chief Captain
RadarMan Chief Captain

Remove your log file and then try to start it.
It will build a new one.
That should do the job.
If, and I say if it doesn't then delete the fsx.cfg file and restart, a new one will be built.
As long as it worked the day you first stopped the first should work.


Jacob_N Guest

The issue now is that FSX isn't installed at the moment, and it won't install for some reason. This surely couldn't be caused by a log file?

I'm assuming the log file belongs to the FSX folder?

I also tried the deleting of the fsx.cfg which didn't work unfortunately.

Thank you for the reply

Pro Member Chief Captain
RadarMan Chief Captain

I'm afraid you lost me.
In your first post you say it won't pass the splash screen.
Now you say it's not installed but you tried to delete the FSX.cfg file??????

Just uninstall it using Microsoft's way (it works for FSX too).


If you follow each step carefully then your computer will be clean of the Sim and you can reinstall it.
The only other way would be to reinstall Windows and start over with a clean hard drive.
Good luck with whatever you decide.


Jacob_N Guest

Apologies, when it was installed it would not go past the splash screen, but then I tried to re-install it, so I uninstalled it then installed it again, but during the install it crashed so it did not complete.

I have considered reinstalling windows and that will probably be my new move.

Many thanks for the help

Pro Member Chief Captain
RadarMan Chief Captain

Let us know how you do and good luck again with whatever your choice.


Jacob_N Guest

It would appear I may have fluked it and fixed my issue.

While messing around desperately trying to make it start, I located fsx.exe, right-clicked it and ticked the option which said "run as administrator" then double clicked the fsx.exe. It successfully loaded.

I'm currently in the process of restarting it a few times every now and again to make sure the issue has gone, looks pretty promising so far.

Thanks again for your help.

Pro Member Chief Captain
RadarMan Chief Captain

Good to hear, thanks for the information.


Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...