Instaling FSX Gold Edition (Error 1935 at the end of instal)

jssjr90 Guest

Basic System Specs:
Windows 7 Ultimate 64bit

So this has been bugging me for the past 6 hours. Every single time I try to install FSX Gold Edition, right at the end of the instillation when the status says its "Publishing product", it gives me a error dialogue box saying;

Error 1935.An error occurred during the installation of assembly 'Microsoft.MSXML2,publicKeyToken="6bd6b9abf345378f",version="",type="win32",processorArchitecture="x86"'. Please refer to Help and Support for more information.

I bought FSX Gold Edition a couple of days ago. I uninstalled FSX Deluxe and removed all of its left over contents and now this...
I have checked in my System32 folder to see what "msxml.dll" files I have and it appears I do not have the one listed in the error.

I have the following files that are related to the one listed in the error in my System32 folder. (msxml3, msxml3r, msxml6, msxml6r)

I tried searching for this file on the official Microsoft website and it appears they do not support the file anymore...

I am at a loss hear. I have probably searched tons of webpages about this issue and it appears that allot of people have come up with this error and all I see is no solutions, or solutions that ultimately do not finish the instillation properly.

I also tried re-installing FSX Deluxe Edition and I still get the same thing. I am installing this on a separate internal hard drive. Keeping it away from my main C drive.

So I was wondering if anyone on here knew what to do. Thanks for anybody that can help.

Answers 4 Answers

Jump to latest
jssjr90 Guest

*Correction on the msxml2.dll missing file on the error, it was relay msxml4.dll. Which I did download from Microsoft itself and placed it into the System32 folder with the other msxml files...still get the same error over and over. On both editions of FSX I have.

Pro Member Chief Captain
RadarMan Chief Captain

Without knowing exactly what the error message says I'm just guessing.


jssjr90 Guest

this is the error message.

Error 1935.An error occurred during the installation of assembly 'Microsoft.MSXML2,publicKeyToken="6bd6b9abf345378f",version="",type="win32",processorArchitecture="x86"'. Please refer to Help and Support for more information.

Pro Member Chief Captain
RadarMan Chief Captain

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...