Fly Away Simulation
SearchSearch 

Planes pulling to right...

Pro Member First Officer
GoodisonBlue First Officer

Hi all

I'm brand new to the world of flight sims with my copy of FSX and i'm really enjoying it.

Learning a lot as I go along but the problem that's really annoying me is planes pulling to the right of the runway as I start take off. It's a real battle just to keep them on the runway

Is this normal and due to engine torque ? or is it a calibration issue on my Joystick ( Logitech Force 3d Pro) (It seems to be calibrated ok in Windows )

Thanks

Pro Member Chief Captain
CRJCapt Chief Captain

Welcome to Flyaway 🍻, Engine torque(propeller aircraft) pulls the aircraft to the left. Calibrate your joystick, ensure that the Rudder and aileron trims are centered(if equipped), turn off all wind. 🙂

Edit-typo (Flyaway) Embarassed



Last edited by CRJCapt on Wed Nov 08, 2006 6:30 pm, edited 1 time in total
Pro Member Chief Captain
CrashGordon Chief Captain

CRJCapt wrote:

Welcome to Flayway

ROFL ROFL ROFL ROFL ROFL ROFL ROFL ROFL ROFL ROFL

Alex The Guest Guest

Hey, i have the same joy stick, and on a previous flight to Vancouver on FS9 with a B734 i had the same problem.

My best bet (and my resolution) was to when incurring this problem, disconnect the the stick and reconnect it, it resets all the controls (i've found that this is actually really effective) and i've been able to fly straight every time. But do try and calibrate it, it might help (it didn't for me).

AAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAlex

Pro Member First Officer
to_coolguys First Officer

Yeah you try disconnecting the stick and connect it back,Then try calibrating..It solved my problems too...

Pro Member Trainee
mat3329 Trainee

Here are a few things you can try, look at your null zone in yoru joystick settings, make sure they are centered, then go calibrate your joystick again. That's what I did to solve the problem that I had wich is the same as yours. Sometimes during flying you'll have to trim your aircraft a bit to ajust it and yes winds can affect your airplane, wich is kind of annoying.

Let me know how you make out bud!

Pro Member First Officer
GoodisonBlue First Officer

Many thanks for all the help - much appreciated

I've improved the problem by moving the stick fully around before starting engine or releasing brakes. It seems by defaut to start on the right but once it's been moved away from that position, it stays central. Stupid thing ! It's nice to be actually going down the centre of the runway now anyway !

Pro Member Trainee
FallonNv Trainee

check your throttles and see if only one side is working it's happened to me only the left side was at full the right side was at idle you can press e+1+2 to get the joystick to run both sides

Pro Member First Officer
Charlie10 First Officer

I had a problem with my rudder full right. I just turned down all of my graphic settings, and to my amazement the rudder now stays in mid position. Lowering all the graphics settings may be one good starting point to isolate/delete a problem. I am a retired radio engineer/avionics inspector and veteran pilot, as well as a computer programmer. I hope I can be of help to others.

Pro Member First Officer
to_coolguys First Officer

Charlie10 wrote:

I am a retired radio engineer/avionics inspector and veteran pilot, as well as a computer programmer. I hope I can be of help to others.

Yeah..we require experienced people like you and pilots in the real world to guide us...Welcome to Flyaway...

All times are GMT Page 1 of 1

Related Questions