Fly Away Simulation
SearchSearch 

FSX Randomly Minimizing

Pro Member Trainee
Saabotr Trainee

Hi All-

I'm enjoying FSX very much except for one consistently annoying problem. In mid-flight, FSX randomly minimizes (does not exit or crash). I can still see that it is running on the tool bar and the task manager. When I click on it to maximize, it doesn't come back. A couple of times it has, but more often than not I end up having to "end task" and start over... very frustrating. Mad

Any idea of what this could be and how to remidy?

Thanks!

FYI... am running:

AMD 64 x2 4600+
Geforce 6800 GS 256mb (overclocked with tons of cooling)
2gb ram

Guest

Are you using any hp printing software per chance? I have the same problem it minimizes FSX FS2004 and other non-simulators I might play such as games. So I have turned it off from running when I want to Fly! hope that helps. Jayofventura

Pro Member Chief Captain
Greekman72 Chief Captain

Stupid thought maybe...Do you have a Screen Saver installed in your computer?Try disable it and check it.Maybe there is a conflict with it.

Also check some other background process which maybe force FS to be minimized,a program or utility that runs from time to time in order to check or update something...(Antivirus,Firewall,Watchdog for your e-mails or something familiar...) Dont Know

Let us know.. Wink

Pro Member Chief Captain
RadarMan Chief Captain

Open the case, clean out the dust, maybe add a fan in the rear (out-going) and see if that helps.

What are your system specs.

Radar

Pro Member Chief Captain
Jake (JarJarBinks) Chief Captain

some times if it minimizes click ESC. then continue flying and it will allow you to see your flight again. as for the problem of it minimizeing i dont have any idea.

Pro Member Trainee
Saabotr Trainee

Thanks for the replies! I do not have any screen savers installed. I have lots of fans... front, back, side, cpu cooling, graphics card cooling, etc...
My motherboard (Asus SLI) came with a handy program that monitors internal cpu temp; everything within proper limits.

I do, however, have HP printing software installed. Before I start FSX though, I make sure to shut pretty much every non-essential program down. Total PF usage before game start is around 250-260 mb.

It's just frustrating when you are on final ILS approach, awaiting a beautiful touch down, when all of a sudden!!! BING! no more cockpit. Oh well, I will continue to play around with some of the software that may have random updates.... that makes total sense.

Thanks again!

Biggin Guest

Did you have any success, if so I would be grateful if you could let me know what you did !

Pro Member Trainee
austingw Trainee

Almost every time I run FSX, it all of a sudden minimizes after a few minutes into the flight.

This kind of behavior in a real plane is unacceptable.

I have A Dell Dimension E510 with Windows XP Home, 3.4 GHz Processor, 2 GB RAM, ATI Radeon X600, Sotck from Factory, no wierd upgrades or tweeks.

Any definitive clues from MSFT would be welcome.



Last edited by austingw on Sat Nov 25, 2006 3:20 pm, edited 1 time in total
Pro Member Chief Captain
RadarMan Chief Captain

You may be overheating.
Clean the dust out of the fans and the heatsink ( dust cakes in the fins).
If you add a fan on the rear grid ( hot air out) that would be a big help.

Radar

Pro Member First Officer
2robplaying First Officer

Have we got to the bottom of this problem yet?

It has started to happen to me since I downloaded and installed the microsoft scenery patch.I have been using fsx since it was released with no major problems(once I got the settings right) but as I say since I installed the patch It randomly minimizes and won't restore.Task manager is showing 100% cpu usage and I have to end task.

Pro Member Trainee
greenlava Trainee

Do you have Instant Messenger of any type running? My FS window minimizes when my "Away Message" pops up, but by the time I get back to my desktop, the away message has gone away. Any other program stealing focus will cause your FSX window to minimize.

Dan

IAP Guest

Hi there,

I've had this problem, which has been SO frustrating. Hovever, I have now solved it, using the following method. Please note that you do the following at your own risk.

It is caused by an autostarting process called HP Commonent Manager, running hpcmpmgr.exe automaticaly.

To solve it, download and a program called Autoruns from Microsoft, available here: http://www.microsoft.com/technet/sysinternals/utilities/Autoruns.mspx. After you run it it will load a list of all programs that autostart on your PC.

Once it has loaded, go to the LogOn tab, find HP component manager (hpcmpmgr.exe), and remove the tick in its box to stop it running on startup.

Restart your PC, and the issue will be solved.

I found that this caused no issues with my PC, and my HP multifunction device runs as normal.

I hope this helps.

Pro Member Trainee
austingw Trainee

Another way to rid yourself of wierd HP startup software, and other undesirable startup software is to use MSCONFIG.EXE.

In Windows XP, either do a search for it or look in here where it is on my machine--> c:\windows\pchealth\helpctr\binaries

Run it and it will tell you all the junk that is loaded at startup time. Deselect items carefully. I've deleted stuff from some machines using this and gone from a slow old dog of a machine to a what felt like a new out of the box machine immediately.

I've been turning off as many background apps as possible when running FSX and it seems to be better. In particular I disable anything HP and I shut off the virus scanner.

mAxiepilot Guest

I used to use Bullguard antivirus and the same thing used to happen to my machine.

I changed the virus software to Norton and that cured the problem

Could it be the same for you?

Pro Member Trainee
Saabotr Trainee

Hi. Thought I would post a follow up. I went with someone's advice (can't remember who it was...) to shut down a lot of unnecessary programs in the task manager. The most important program that I end is the "hpcmpmgr.exe." It's an HP software program that, I believe, searches for updates at inopportune times (like final approach after an 8 hour flight). So, bottom line for me is to shut down inconsequential programs. This also frees up some more memory.

It seems like I have to go through an entire process when starting FSX... but it's worth it! Very Happy

n00b Guest

Hi,

when i minimize FSX, (taking screen shots) the programme never restores. The task manager shows 100% CPU usage, then i have to end task to take the next shot. This really fustrates me!

help appriciated

bobbyz Guest

I apologise in advance because this will probably be of no help, but I have had this problem a few times and have found that the only way to get the prog to maximise after it has minimised is to open up task manager, highlight FSX in Applications tab and then click the "switch to" button". This brings the prog back.

Sorry if this is no help.

Guest

Hitting the escape key worked like a charm for me.

Thanks for the suggestion.

Uncle Bill B.

frustrated too with this Guest

So haven't fixed this problem yet either. I click on free flight and immediately it minimizes and will not come back when clicked on. Absolutely NOTHING else is running on my pc I have always killed all things that auto start. I use msconfig after every install and everyday to make sure there is NOTHING running except explorer and system services (winlogon,spoolsv,svchost,lsass,etc) BUT.....

At least I found a temporary solution hold alt and push tab until you highlight flight simulator x then release alt and the game should come back full screen sometimes you have to alt-tab out and alt-tab to FSX again but at least you won't lose your flight.

Ekilmer Guest

Just last week my installation of FSX started doing this, also. It's very frustrating. Thanks to all the posts, I poked around and eliminated services, but that didn't help. I disabled so many services that I got to the point where FSX wouldn't even run.

On my Windows 7 system, the minimizing occurs every hour on the minute. The only way I can get it back is to switch back to it in the Task Manager. If I wait more than a minute or so to do that, my monitor goes black and nothing works except shutting down the computer and, sadly, losing my flight.

After nearly five years of good flying, I am now plagued by this strange behavior. Does anyone have more suggestions? Thanks.

Ekilmer Guest

This appears to be a dead thread, but I thought I would post a viable solution to the random minimizing problem in case anyone cared.

I normally run FSX full screen, but I tried running it in a window, albeit a maxmized window, and now when the minimizing occurs, all I need do is click in the FSX window to regain the focus. The FSX window does not minimize, though the focus moves away and the sound stops. A single click inside the still visible FSX window regains the focus and everything is as it was. All I have to put up with is the window title bar. As far as clicking inside the window, most of the time I'm clicking somewhere in it anyway and usually one of those clicks takes care of the focus.

Guest

My Dad had the same issue, and we thought it was something to do with Sceneries but it turned out that after uninstalling FSX Recorder it started to work again! No more minimising!

I know it is an old thread but I thought it might help someone so it is worth sharing.

Guest

It turns out that it actually was something else:
In your fsx.CFG change:
VirtualCopilotActive=1 to 0

So it looks like this:
VirtualCopilotActive=0

Problem solved!

aledodj Guest

I know this is an older thread, but what worked for me was...

CTRL + ALT + Delete to open task manager...then double-click the game.

Eric Muetterties Guest

Went into MS Security essentials and added all folders FSX related. Steam folder on my C drive and User FSX folders on C drive as well as E drive FSX folders. I also shut off add-on sceneries and will add them back one at a time. MS did an update and so did MSSE after that it had quit working. Flying again..l

ReedMaxson Guest

FSX started minimizing to task bar after about 5 minutes of flight.  This started happening after I upgraded to Windows 10 from Windows 7.  I never had the problem before Windows 10.  I am able to restore the flight by pressing Alt then Enter (sometimes do the sequence twice).  The flight returns in paused mode.  Press p to continue.  It does not minimize again until starting a new session.  I have not yet determined the cause.

All times are GMT Page 1 of 1

Related Questions