Joystick throttle not working correctly in FSX

Robin Hutter Guest

Hi there,

My joystick (Logitech Extreme 3DPro) throttle control doesn't work properly anymore in FSX. Power can be set to between approx. 20 and 60%, sometimes it won't even do that. Joystick calibration works OK, and RAW data look good. Everything works normally in FS2002.

Anyone got some clues???

Robin <><

Answers 17 Answers

Jump to latest

in fsx, go to settings and calibrate the stick.

Robin Hutter Guest

I calibrated the stick more than once. Calibration rotines show the stick is calibrated OK. The raw data displayed vary between 0 and 255. The stick works fine in FS2002. This ist *NOT* the problem! There seems to be a misfunction in the way FSX reads the raw data. I can adjust the three axes roll pitch and yaw, but I can't adjust the sensibility of the throttle control.


FSX is the receiver of data... it is a passive device.

i.e. the worst that can happen is GIGO

Pro Member First Officer
Jim (jellrod) First Officer

Have you gone into your SETTINGS and checked to make sure you have the Throttle(s) set for joystck? There are four Throttles. My joystick has two seperate throttles that I have to assign in the SETTINGS area of FSX for it to know I'm using the jopystick throttles and not the keyboard throttles. SO check in your SETTINGS area and ensure you have the joystick throttles assigned accordingly.

Pro Member Chief Captain
Jake (JarJarBinks) Chief Captain

your type of joystick...


has a reputation for problems.

try unistalling the program for the stick that you installed with the CD that came in the package. then reinstall. or if worse comes to worst buy a new stick

i special ordered a X52 and it took 2 months but it was the best decission i ver made relating to this situation

Pro Member First Officer
Jim (jellrod) First Officer

He says it worksd in 2002 so I'm not sure its the stick (altho stranger things have happened with Logitech) I'm interested to see if the Settings for the joystick are set-up. I know when I switch between single double and four engine, I tend to forget to go in and change the throttle quadrant settings.

Robin Hutter Guest

OK, Thanks for the suggestions. I looked for the settings that jellrod mentioned. OK, I'm trying to translate this, as I am using a German version, but I hope you get the idea. In the main menu screen I chose "Settings" on the left and "Controls..." in the "Additional settings" area to the right. The "Controller" itself is activated. Controller-Type says "Logitech Extreme 3D". Below, I have the three axes with their respective sensitivity sliders. These are all flat left.
The third tab is named steering axes. Here again, the Controller Type is "Logitech Extreme 3D". Flight modus is "normal". The 10th setting ("power axis" between "flaps" and "propeller" is mapped to the throttle control on my joystick. I deleted this, reassigned it. This correct.

So I guess, I am stuck. I will try to uninstall the joystick and re-install ist. I will post results here. And I will talk to my minister of finance (my wife) about getting a new joystick. ;- This might be a good pretext...

Pro Member First Officer
Jim (jellrod) First Officer

gruss gluck mien Fruende

logiupdate Guest

there is a new update from logitech for that joystick? Idea


check logitech website for updated driver.

Robin Hutter Guest

Hi folks,

just wanted to thank everyone who tried to help. I'm not quite sure, what helped in the end. Uninstalling the joystick didn't work, because I didn't install it. So I unplugged it and removed it from my hardware manager. In addition I unchecked the "use joystick" in the FSX settings. Replugging the joystick, re-enabling it in FSX, resetting to default and re-assigning my F-keys finally worked. My throttle is working again. Can't tell what was the problem, or how I solved it. But I can tell you: I won't touch a thing about that joystick as long as it's working... Wink

And, jellrod, I guess you have to practice your German a little bit before you can really use it. 😂

So, thanks again everyone,
Robin <><

noproblemo Guest

i never did know of logitech ever giving any type of problems with drivers or anything like that, they always seem to work on everything!
and i didn't see any improvement in the updated driver, didn't need it, worked fine with out it. Surprised

&/$:@)! Guest

First go to "Settings" then "Controls" then click "calibrate". After you do that click "Properties". A request to calibrate your joystick will pop up. Once it does click accept and then do all of the tests.

PitchBlack Guest

it is important to set the Throttle AXIS Sensitivity to max. than and only than FSX is recognizing the whole axis.


willie97 Guest

I am having trouble with the throttles on my fsx steam simulator. after a couple of flights i do a flight planer then wehn i am ready to go and being towed out. As soon as i leave the aircraft turns left only left throttle works. I havea thrustmaster flight 4 joystick

Pro Member Chief Captain
RadarMan Chief Captain

Clean out the old drivers and try the new ones.


Pro Member Captain
Ian Stephens (ianstephens) Captain
Ian Stephens is an expert on this topic. Read his bio here.

Hey Robin,

It's great to hear that you were able to resolve the throttle issue with your Logitech Extreme 3D Pro joystick. Although the exact reason behind the issue remains uncertain, I'd like to offer some insights to help you and others who may encounter similar situations.

In some cases, FSX may have conflicting input settings that interfere with joystick functionality. Here's a rundown of steps to check and adjust settings:

  • In FSX, go to Settings > Controls > Calibration.
  • Make sure the Enable Controllers checkbox is selected.
  • Click on the Change Assignment button and confirm that throttle axis is assigned to the correct control.
  • Ensure that no other axis or input is assigned to the same control, as this may cause conflicts.

If the issue persists, it's worth checking the Logitech Gaming Software (LGS) to verify that the joystick's throttle axis is properly configured. You can download LGS from the Logitech support page.

  • Open LGS and select your Extreme 3D Pro.
  • Go to the Axis tab, and verify that the throttle axis is assigned correctly.
  • Check for any conflicting commands in LGS, and remove them if necessary.

Another possible solution is to delete your FSX.cfg file to restore default settings. This file is usually located in your %APPDATA%\Microsoft\FSX folder. Be sure to back up the file before deleting, just in case you need to revert any changes.

Lastly, updating your joystick drivers and FSX to their latest versions may help resolve compatibility issues.

I hope these suggestions prove helpful in case you run into similar problems in the future. Enjoy your flights, and happy landings!

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...