Fly Away Simulation
SearchSearch 

FSX every plane tilts to the left

Martok Guest

Hello, I just found your forum and it seems the right place to get help.
I played FSX before, on the same PC but with another controller.
Since I re-installed the game, every plane, in any condition and any realism setting tilts to the left in flight. Jet planes, propeller planes with one or more engines the situation is the same. I have to set the rudder almost all the way to the left to keep the plane straight.
What I already considered:
Weather conditions
Different airplanes
Remove and re-plug Joystick
Uninstall and re-install the game
different realism settings
Propeller and torque to 0
Thermal set to "none"
I have never had such problem before on the same computer.
Any suggestions?

thank you all very much

Pro Member Chief Captain
Tailhook Chief Captain

Martok I can't help but think that you are a double-agent of sorts... you give us all kinds of information - some or most of it quite useful yet... you're withholding that most important bit of intelligence:

The controller or your flight controls - brand etc..

Further you are not very transparent when you tell us all the actions you have considered... I hope you won't think me patronising when I tell you that considering an action and actually executing it are two different things.

"Uninstall and re-install the game" - simple question: Did you or didn't you?

My logic is simple. Had you uninstalled and re-installed the sim only to find that the problem persists, chances are that something's wrong with your flight control(s). It could be broken or wrongly calibrated.

I've been using the Saitek X52 PRO for at least a couple of years now - have a look at the picture if you're unfamiliar with it: http://www.saitek.com/uk/prod/x52pro.html

As you can see, both the throttle and the stick are lit up like a Christmas tree. About three or four months after I had started using those controls, all the pretty little lights on my throttle went out... never to light up again. The lights on the flight-stick kept on shining though, so I figured it must be a loose wire or wear and tear and since the controls continued to work perfectly otherwise, I decided to live without those pretty little lights on the throttle.
I should mention that those events happened while using an older PC running W XP Pro.
My current machine is about a year old now and I'm running W7 Pro 64 Bit. When I made the switch, there were absolutely no issues with my flight controls - plug and play - as they say, except of course the pretty little lights on the throttle were still dead... never mind.
I don't use the 'automatic updates option' for MS Windows, preferring to do it manually. However sometimes I forget but the handy little icon in the taskbar lets me quickly check if and what kind of updates are available.

Three days ago after one of my prolonged intellectual hiatuses I got my act together and did a bit of house (computer) cleaning, maintenance etc. Checking for updates I was surprised that apart from the usual security fixes there was an optional update for my Saitek flight system... WHAT???
Somehow this didn't make any sense at all however I took a leap of faith, downloaded and installed the Saitek update (keep in mind that this came from the MS update labyrinth) and guess what? No damage was done - everything works just fine and in addition all the pretty little lights on my throttle are alive again.

Moral of the story: My flight controls which obviously were conceived well before the birth of W7 probably required some sort of driver for this OS.

Many moons ago I too had an issue with ANY aircraft pulling to the left (using the Saitek system) - I eventually figured out that my fiddling with the knobs and sliders had caused that, so I centered them and put them back into their default positions and everything was honky-dory. Another Flyaway member who had the same problem managed to get everything back on track after I had related my experience... he'd found out that his little daughter had played with his controls -- well, there you go.

But what if you don't have a Saitek setup or something along similar lines, something very simple where you can't mess up with sliders, buttons and knobs?

As mentioned initially, a fresh install of the sim will probably fix the problem... but wouldn't it be nice to know what caused it in the first place and thus avoiding the arduous task of the old uninstall re-install routine?

The problem you're struggling with is not an anomaly or something inexplicably weird because well, "that's what happens when using computers". This problem started appearing the first time when MSFS incorporated an autopilot into the sim.

We should spare a bit of time and think about what actually happens when we save a flight. Imagine you're at the end of a long-haul, you're tired, concentration has evaporated and your approach is a difficult one and to complicate matters even more, your first officer just died of food poisoning yep, you're flying for a budget airline and the fish on the menu was a wee bit old. Since we're flying in a virtual world, you think I don't wanna screw up the approach and landing... I'll save the flight and finish it manana when I'm fresh.
...except manana doesn't exactly happen the way we had planned and by the time we get back to our sim, which could be a few days later, we don't even remember what our last flight was... let alone the premature demise of the first officer Harold.

Regardless of what aircraft you choose, your place of departure or your destination, whether you're carting vomiting passengers or a cargo of iffy fish (- or both), you're not even half way down the RWY and you can bet all hell will break loose but, being the experienced aviator, the ace that you are and always ready for a challenge, you manage to get the crate airborne, avoid colliding with the control tower and end up being tossed around like a leaf in the wind while you feverishly run through all the checks you should have done BEFORE you put the pedal to the metal.

Well, if you're tenacious and a sucker for punishment, you might be able to find your way out of the chaos and save your cargo of rotten fish, suffer a mild heart attack and age 10 years in 5 minutes... if you're smart, you pull the plug and enjoy life. 😛

...oh, and don't forget to delete those saved flights BECAUSE they somehow lock the AP settings from previous flights into the computers memory. Idea

So to recap: Make sure your flight controls are calibrated, if the problem persists, try and find the saved flight with the pesky AP settings and delete it... if you can't find it, delete ALL saved flights.

I am aware how obsessed some FSX aficionados are with their flight history, reward points and the like... regardless, I give you my personal guarantee that you will live to tell the tale should you decide to follow this course of action.

Good luck 😀

Martok Guest

Let me start with thanking you for your reply. I can assure you I am not a double-agent, however if I was I'd probably say the same 🙂
I'm a rookie pilot, used to use a MS Sidewinder force-feedback 2 until it exhaled it's last breath and now I'm playing with a simple Logitech 3D Extreme ( http://www.amazon.co.uk/Logitech-942-000005-Extreme-Pro-Joystick/dp/B002BYONB0/ref=sr_1_3?ie=UTF8&qid=1331240799&sr=8-3 )
The computer is the same one as I used trying FSX my very first time with the Sidewinder FF2, intel core2 quad. Difference is the OS, which used to be a Vista business 32, and now it's a W7 Ultimate 32.
With the joystick came the driver's DVD with W7 support. In the calibration everything seems OK, the controller has no particular "tendencies".
I did uninstall the game, including the saves, and re-installed with the acceleration pack. Same thing... I did not notice if without engaging the autopilot the problem is still there.
But once the problem IS there, disengaging the autopilot does not help, dropping the joystick in the middle bring the plane to the right as if the rudder was turned that way.
I will however try and search for newer drivers, and eventually re-install the game once more.
One question just jumped in my head now though, even if my controller is a basic one, could it be that one of those 12 buttons might have moved something out of place??

Martok Guest

UPDATE: after uninstalling the game again, uninstalling the Joystick's drivers, and reinstalling game and controller the problem magically vanished. To keep me on my toes now the game crashed while updating the real weather conditions. great.
P.S. is this forum an active one still?

Pro Member Captain
David (The-GPS-Kid) Captain

It sounds like your FS is loading with the flight control surface settings from the last flight, and that you may have some trim messing things up.

Try this:-

Go into FSX Control settings and in the keyboard/buttons list, look for "Center Flight Controls" or similar. By default it is assigned to the NUM 5 key. Make sure it is assigned.

Now load up FS and press that button. It will centre (I'm English so spell it this way!) your flight controls and hopefully solve your problem.

Cheers.

Blue Max Guest

I had the same problem for quite a while, and it was also one of the "centre Trim" Keys not assigned and therefore not pressed.

It's a great sim though! 😀

Cheers,

daztats Guest

I had problem of joystick pulling to the left,
I reinstalled, brought a new joystick, got a new pc and tried everything I could find on the internet.

Today I found a cure for me, maybe it will help some of you out too. Or maybe help towards a new fix who knows.

Anyhow, Way I fixed was lowered realism settings to easy, tested game and stick worked fine. Then increase the difficulty setting to hard tested again and it pulled left yet again 😞.

I found with custom settings everything on hard/most realistic, I needed to have P-FACTOR & TORQUE off/easy
Tested again and it works great no left pull at all.

Hope this helps at least 1 of you out 🙂

Scott Munroe Guest

Control - shift - C worked for me just now.

All times are GMT Page 1 of 1

Related Questions