Fly Away Simulation
SearchSearch 

Trim

Pro Member First Officer
amermel First Officer

I'm getting flight time in a Cessna 172. I fly the plane on autopilot. When I take off the plane rolls to the left. Also when I am on the approach it rolls to the left but I don't know how to fix it. I have a Ch Products Flight Sim Yoke which has electric trim on it but it's not working it just rolls the plane more to the left. Please help I get very frustrated because I cn't my my approach correctly and I am trying to get flight time to become a real pilot. Please help.

Pro Member Captain
Jared Captain

Well if you want to use FS9 as a real life sim you should get the F1 Cessna Skyhawk. How are your realism settings. If you have the torque then you need to add right rudder just like in real life.

Pro Member Captain
WarHawk42 Captain

amermel wrote:

I'm getting flight time in a Cessna 172. I fly the plane on autopilot. When I take off the plane rolls to the left. Also when I am on the approach it rolls to the left but I don't know how to fix it. I have a Ch Products Flight Sim Yoke which has electric trim on it but it's not working it just rolls the plane more to the left. Please help I get very frustrated because I cn't my my approach correctly and I am trying to get flight time to become a real pilot. Please help.

The first thing I would do if I wanted to be a real pilot is turn off the auto pilot. Learn to fly the plane and don't depend on auto pilot to do it for you.

Since you are using auto pilot it may be compensating for the roll to the left when it's on, turn it off and see if the plane then still rolls left. If it does then it sounds like you need to calibrate your control. One other thing you might try, increase the null zone for the rudder control. My stick will tend to cause the plane to bank left if I don't increase the null zone from the default setting.

Pro Member First Officer
amermel First Officer

Thanks guys but when I have the Auto pilot off it still rolls. I have the Autopilot on because I cant keep the plane straight and level because the plane is trimmed horribley. I have the realism setting all off because I wanted to see if the plane still rolled with the realism settings like that but it still does. Also I told you guys many times that that the PLANE ROLLED Twisted Evil not yawed to the left. So yeah. I just wanted to tell you that.

Pro Member Captain
WarHawk42 Captain

This sounds like a calibration problem. Have you checked for updated drivers for the CH controller? I have an older CH yoke and it works perfectly, but I don't use the trim controls on it, once I center it I use all trim controls in the sim.

Set your weather at calm and use the keyboard for flying instead of the controller. If it still rolls right then it's something other than the controller, if not you have some kind of problem with the controller, or if you have another controller you could try, try it.

spuddi Guest

have you tried turning the p-torque down

Pro Member First Officer
amermel First Officer

i have turned the p-factor all the way down and it still does it. ill try to unhook the controller. But when i installed the controller the controller wouldnt work so i had to take the computer to a computer store and in the end the computer worked with the controller and it costed about 200 dollars so yeah i dont want to spend that much miney if i unhook it again.

Pro Member Captain
WarHawk42 Captain

amermel wrote:

i have turned the p-factor all the way down and it still does it. ill try to unhook the controller. But when i installed the controller the controller wouldnt work so i had to take the computer to a computer store and in the end the computer worked with the controller and it costed about 200 dollars so yeah i dont want to spend that much miney if i unhook it again.

I think it would be helpful if we knew your computer specifications. Something isn't right here.

What operating system are you using?

Hooking up or unhooking a controller should not create any problems. I switch controllers all the time without any problems.

All times are GMT Page 1 of 1

Related Questions