Fly Away Simulation
SearchSearch 

trouble landing

Guest

I am having trouble landing in FS9. Say i want to land at lodnon gatwick. I will look at the ILS frequency and heading of the runway, say the runway heading is 230 and frequency 110.45. I will put my course heading indicator to 230 and set NAV1 radio to 110.45 for example. I will line up with the localizer and my plane will be flying on heading 230 with localizer centred. The localizer will veer off although i am still heading 230. My glideslope and flaps, spoilers etc are all set correctly with landing gear down but the time i have corrected the localizer i am already landed on the grass. Why is this happening as when i use the autpilot approach mode the plan may fly 2 degress out at say 228 degrees and be lined up perfectly, any help? 😕

Guest

i forgot to add this happens with clear weather no wind, i could understand crosswunds but with winds calm i dont understand why this is happening.. ❓

Pro Member Chief Captain
CRJCapt Chief Captain

Confirm the airport code/name, runway, aircraft you're using and I'll take a look. 🙂

Note: The autopilot should be off before 200' AGL. The standard ILS/autopilot can't land the aircraft.

Pro Member Captain
Doyley Captain

Well it can but your landing gear or passengers wont be very happy Wink

I have had problems with ils at EGNS rwy 8. You may be experiencing a similar problem. Turn on visual flight path and see if it is following it.

BashDaBish Guest

Have you swithed from GPS to NAV? I noted you gave Gatwick as a general example so I assume it happens at all aiports?

Pro Member Chief Captain
RadarMan Chief Captain
Pro Member Captain
atreyu Captain

did you put the right course in for the ILS landing?

Pro Member Chief Captain
Solotwo Chief Captain

Quite a few ILS approaches on FS are really buggered up, my home airport has only one runway that the ILS actally works decent, one runway it guides you down and lines you up, but to the right of the runway by about 50 feet or so, and then the other runway you put the correct ILS frequencys in and then the glideslope feature doesn't show up and if you put it on autopilot it spins the plane around 180 degrees and does all sorts of annoying things.

All times are GMT Page 1 of 1

Related Questions