Fly Away Simulation
SearchSearch 

aircraft overstressed

angelogg Guest

😞 Aircraft overstressed !!!!! *fly ends* ill be more careful next time*

Pro Member First Officer
davidmac1 First Officer

You know you can turn this off if you dont like it? yes?

angelogg Guest

Yeah i know.. but if i set the settings to maximum reality that option is activated ....

Pro Member First Officer
davidmac1 First Officer

Just making sure.

Can i ask what you were doing at the time? Drunk?

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

Excessive speed by at least 25kts for a long period of time, or excessive G forces will cause aircraft stress. Its quite hard to overstress an aircraft on one flight. If you do overspeed, try and reduce speed as soon as possible and make small adjustments on control surfaces 😉

joeltheboss Guest

Happens to me sometimes, and it anoyes me really much, especially when I don't know how to diasble it. Can somebody please help me?

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

joeltheboss wrote:

Happens to me sometimes, and it anoyes me really much, especially when I don't know how to diasble it. Can somebody please help me?

Press 'ALT' while flying in FS and then go to 'Aircraft' -> 'Realism'.

😉

Pro Member Chief Captain
Solotwo Chief Captain

Just stop overstressing the plane and you won't have that problem. 😳

Pro Member Chief Captain
Greekman72 Chief Captain

Solotwo wrote:

Just stop overstressing the plane and you won't have that problem. 😳

I agree...If we turn off realism why are we flying?

My opinion 😉

All times are GMT Page 1 of 1

Related Questions