Navajo Panther Engine Cut-Out

Danny559 Guest

Many months ago I downloaded the FSD Navajo Panther for FS9. It's always worked a treat - until now! Now, the engines always cut out after a few seconds. Even if I restart the engines, they each will only run for about 10 or so seconds, then they cut out! I've checked that I have no engine failures (or any others selected) but that makes no difference. Can anybody help?!

3 Responses

Pro Member Chief Captain
CRJCapt Chief Captain

Check a few things:
1. Mixture may be full rich at a high altitude airport. What airport?
Try it at KMSY.
2. Check that fuel valve(s) are in correct position.
3. Check that required fuel pumps are on(checklist).

Danny559 Guest

Thanks for the reply - but I don't think we've cracked it...

The problem happens at any airport. The fuel valves are in the correct position. As for the fuel pumps, I've tried switching them on, but the switches just 'twitch' when I try - they don't stay on. That said, they always did that in the past and there's never been any problem before.

Guess I'll have to try reloading the aircraft. It's just that the dwonloaded file that I saved (and paid for) doesn't seem to work any more either, so I might end up having to pay for the 'plane again. Shame really, I really like this one - and I used to be an observer/engineer on one years ago!

capceo Guest

Go into your load manager and repair your engines. I used to have the same problem.

All times are GMT Page 1 of 1

Related Questions