Fly Away Simulation
SearchSearch 

SP2 Rolls back...

Pro Member Trainee
dan_cbw Trainee

Hi, I installed Service Pack 2 last night (its the first time playing FSX for about 5 months) and it worked perfectly, however today I had to do a system restore on my PC for other reasons, which meant FSX SP2 was not installed. So I go to install it again after the restore and as it gets about quarter way of 'Caching Files' it suddenly Rolls back the installation and a message pops up saying:

"Microsoft Flight Simulator X Service Pack 2 Setup Ended before completing installation. Your system has not been modified. To install this program at a later time, please run Setup again."

I've tried multiple things such as uninstalling the whole of FSX and installing it again, then SP1 then SP2, but fails still. There seems to be no way to install SP2 on my PC now...has anyone else come across this problem?

My Specs are:
Windows Vista 32bit
Intel Core Quad Q6600 2.4GHz
2GB DDR2 Ram
nVidia GeForce 8600 GTS

Pro Member Trainee
PilotSergio Trainee

Same problem, any idea how to fix it, I also did a restore before trying to install it again.

Pro Member Trainee
dan_cbw Trainee

I Managed to fix mine a few days after I made this thread, I dont really know what I done other than uninstalling FSX completley (even though I tried that before making this thread and it still didnt work) and installing it all again.

On another note I had to install SP2 again yesterday (as FSX kept coming up with a fatal error on startup) without any problems.

All times are GMT Page 1 of 1

Related Questions