Fly Away Simulation
SearchSearch 

FS 2004 Rudder Problem.

Pro Member Trainee
frogdog33 Trainee

HELP! When starting flight in FS 2004 w/ Beechcraft King Air...my rudder defaults to 70-75% right. NUMPAD5 does nothing to correct. Result...I am all over the taxiway! Am I doing something wrong somewhere? I use a Thrustmaster Couger HOTAS but have no seperate rudder controls. FS settings are set at AUTORUDDER. Thanks. FROGDOG

Pro Member First Officer
George Leach (CDR) First Officer

If you have rudder pedals or a joy stick that twisters R & L un check auto rudder.
If none of your movements work go and control panel in your pc then to game controllers and reset controller

Pro Member Chief Captain
RadarMan Chief Captain

If that won't work then try this.
Many joysticks seem to have a problem with either right or left pull.
Try here for the answer to your particular problem, I hope they can solve it.

http://forums.frugalsworld.com/vbb/forumdisplay.php?s=&forumid=38

http://ts.thrustmaster.com/eng/

Radar

Pro Member Trainee
Scott Archbold (Scotteiboi) Trainee

I have also had the same problem with my joystick, all I did was reset the controls by doing this: Press alt when flying in FS9>>>Options>>>Controls>>>Calibrate Joystick, and move the jotstick around until everything is in the center postion then close. ^^,

Guest

You should also check that AutoPilot is off..... that's a classic ...

Pro Member First Officer
George Leach (CDR) First Officer

Guest you forgot to sign in ?
What is your name ?

Pro Member Trainee
ortegren Trainee

Sorry 'bout that. Didn't realize I wasn't logged in...

All times are GMT Page 1 of 1

Related Questions