Saitek Rudder Pedals: Toe Brakes Don't Release

Pro Member Trainee
escrge Trainee

Using the Saitek Pro Rudder Pedals with FSX, my toe brakes don't disengage when I lift my foot off the pedal. I have to engage/disengage the parking brake to release the brakes completely.

What am I missing?

Answers 8 Answers

Jump to latest
Pro Member First Officer
Accelor First Officer


I use CH pedals but its possible that your problem was the same as mine.

Under settings, control axis assign the left, and right petals by clicking on them, then push the appropriate pedal then, tick the reverse box to the right. That should do the trick. 😀

Pro Member Trainee
escrge Trainee

Yeah, I've already tried that. I tried it again just now and what happens, is that the red BRAKES indicator in the lower left corner of the screen comes on and doesn't go out.

But I just figured out what my problem was. The sensitivity was set too low. The default setting was set to half and I changed it to full. That seems to have done the trick.

Pro Member Trainee
Philc172 Trainee

I am running fsx in windows 7 I just added the saitek yolk and throttle quadrant with rudder pedals and had the same problem with the brakes staying on. to fix it I took your advice and yes you have to set the sensitivity to full and have to Under settings, control axis assign the left, and right petals by clicking on them, then push the appropriate pedal then, tick the reverse box to the right.

thanks for the advice

Rik Ninestein Guest

Hi Guys, Thanks for answer to brake problem 😂

rudder pedals Guest

Thanks for the tip guys. I have been fighting this thing for weeks. Cheers

Rodrigocouto Guest

Thanks buddies...problem solved !!

Pro Member Captain
Ian Stephens (ianstephens) Captain
Ian Stephens is an expert on this topic. Read his bio here.

Hi there,

I understand your frustration. I've been tinkering with flight simulators for a considerable time and have come across this very issue a few times myself. So, let's dive right into it and see if we can get your Saitek Pro Rudder Pedals working smoothly with your FSX.

Firstly, let's clarify a few terminologies that I'll be using:

FSX is short for Microsoft Flight Simulator X, a highly popular flight simulation software.
Toe Brakes are an integral part of the Rudder Pedals that simulate the braking action in an aircraft.
Engaging refers to the action of pressing the toe brakes, while disengaging refers to the action of lifting your foot off the brakes.
So, from my knowledge, your issue seems to be related to an axis assignment problem, which is a common issue amongst various simulation platforms, not just FSX. Microsoft Flight Simulator 2020 and X-Plane 12, two popular flight simulators, have also seen such issues.

Here are the steps you can follow to hopefully resolve your issue:

Check your axis assignments: FSX, like most flight simulators, allows you to assign different controls to different axes. In your case, make sure that your toe brakes are assigned correctly. Navigate to the 'Settings' menu, then 'Controls', and finally the 'Axes' tab.

Re-calibrate your Pedals: Sometimes, your pedals might need re-calibration. This is generally done via the device's own software or the 'Game Controllers' option in the Control Panel.

Check for conflicting controls: Sometimes, having multiple controls assigned to the same function can cause issues. Ensure no other control is assigned to the brakes.

Test in other simulators: If possible, try to test your pedals with another simulator such as Microsoft Flight Simulator 2020 or X-Plane 12. This might help you identify if the problem is with the pedals or FSX.

Update Drivers: Lastly, make sure that you have the latest drivers for your Saitek Pro Rudder Pedals. Outdated drivers can often cause such issues.

Please follow these steps sequentially and you should be able to diagnose and hopefully fix your problem. Remember, simulation platforms are complex pieces of software and sometimes the solutions require a bit of trial and error.

If none of these work, you might need to consider getting a replacement if your pedals are still under warranty, or have them repaired. However, from my experience, one of the above solutions should help you resolve your issue.

Best of luck, and happy flying!

Tony Worrall Guest

Just bought new pedals for my MSFS X and had this problem as hundereds of other people have had according to internet.
Found this solution after lots of hunting. What a relief
. Go to Options - Settings - Controls  Select Saitek Pro Flight Rudder Pedals in drop down menu Select Simple Controls not the Advance Controls Set Sensitivity slider all the wat to the right Set the Null Zone slider at about 5 Go toControl Axes   Set Brake (left axis) to the X Axis and Tick the Reverse box Set Brake (right axis) to the Y Axis and Tick the Reverse box


Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...