Fly Away Simulation
SearchSearch 

Stuck Brakes

Rick108 Guest

I am a student pilot, just bought FS2004 to use for practice. I'm flying the C172, but the red word "BRAKES" is constantly in the lower left corner (other planes, too, by the way). Settings says the period key should release them, but it does nothing. I have tried remapping the Brake (Apply/Release) funtion to other keys, but still no luck. Everything else seems to be working ok, and I can (eventually) take off with the brakes on, but I can't figure out how to release the brakes. I am using the CH USB Yoke and Pedals, if that makes any difference...

Any ideas?

Pro Member Chief Captain
RadarMan Chief Captain

Try in controls and uncheck the reverse box for the pedals.

Radar

Guest

RadarMan wrote:

Try in controls and uncheck the reverse box for the pedals.

Radar

Thanks, RadarMan. I tried it, but no change. Also, I should note that the toe brakes don't seem to work ("reverse" checked or not), even though they calibrate fine and test ok - I can see the X and Y axes move. I assumed it was because the BRAKES were stuck on anyway, but maybe that is another clue... Should the Reverse" box normally be checked or not? It came checked by default, because I didn't do it!

Pro Member Chief Captain
RadarMan Chief Captain

I never used the yoke or pedals but don't you press toe up for one function and heel down for another.

Try going into the control panel of the sim (in settings) and assign a button on the yoke for breaks and see how that works.

I use a stick and my trigger or the "." works for me.

Radar

Rick108 Guest

Yeah, when I tried different key assignments, I also tried a couple of yoke buttons, too - they seem to be ignored, just like the "." key. However, I can assign any OTHER function to a button and it works just fine. Just not the brakes... It's like there is some master setting that says "jus keep the brakes on always and forever"... It's driving me nuts... I'm going to bed now. Thanks for the suggestions!

Pro Member Chief Captain
RadarMan Chief Captain

Remove the brake message from the screen?

Add the following line to the (SIM) section of the f9.cfg file:

show_brake_message=0

The problem, I don't know if this removes the sign and the function or just the sign.

Radar

Pro Member Chief Captain
RadarMan Chief Captain

Idea Thinking, yes I know that hurts.

If you get the break sign off and are ready to start a flight, why not save that flight as your default flight.
You can always change aircraft and other settings (airport, time season etc).
All you do is press "Alt" and the tool bar appears at the top.
It's a workaround but it will be easier than reinstalling the sim and possibly getting the same problem back again.

Radar

Guest

RadarMan wrote:

Remove the brake message from the screen?

Add the following line to the (SIM) section of the f9.cfg file:

show_brake_message=0

The problem, I don't know if this removes the sign and the function or just the sign.

Radar

This sounds interesting, I'll give it a try tonight when I get home and report back (unfortunately at work now...). And yes, good idea about saving the flight, too, if I ever manage to turn off the brakes. Thanks, RadarMan.

Another thought (really hurting now...) - does anyone ever post updates or patches to the FS2004 software? Maybe they "fixed" something related to this problem?

Do you ever sleep???

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

Anonymous wrote:

RadarMan wrote:

Remove the brake message from the screen?

Add the following line to the (SIM) section of the f9.cfg file:

show_brake_message=0

The problem, I don't know if this removes the sign and the function or just the sign.

Radar

This sounds interesting, I'll give it a try tonight when I get home and report back (unfortunately at work now...). And yes, good idea about saving the flight, too, if I ever manage to turn off the brakes. Thanks, RadarMan.

Another thought (really hurting now...) - does anyone ever post updates or patches to the FS2004 software? Maybe they "fixed" something related to this problem?

Do you ever sleep???

Microsoft released an update (9.1) but I don't think that it was a significant problem - I've never heard of it before Dont Know

You have some good advice - let us know how you get on with it. 😉

Pro Member Chief Captain
RadarMan Chief Captain

Anonymous wrote:

RadarMan wrote:

Remove the brake message from the screen?

Add the following line to the (SIM) section of the f9.cfg file:

show_brake_message=0

The problem, I don't know if this removes the sign and the function or just the sign.

Radar

Do you ever sleep???

Between posts 😂 I'm on the West Coast of the US.

Radar

Harleyman1 Guest

The West Coast....And I had you pegged for a Yankee .... 😛

Pro Member Chief Captain
RadarMan Chief Captain

Harleyman1 wrote:

The West Coast....And I had you pegged for a Yankee .... 😛

Dodger blue, all the way. Back before you were born.

Radar

Pro Member Captain
Sam (SamIntel) Captain

You know, I have this same problem with my pedals. I fixed it by going into the sensitivity settings for the pedals, and clicking Reset To Defaults. If I keep them on the default setting, they seem to work.

Rick108 Guest

Due to a thunderstorm followed by a power failure, I didn't make much progress last night. However, I DID get to define "show_brake_message=0" and the annoying red "BRAKES" message no longer appears in the lower left corner! However, it still seemed like the "." key had no effect and the toe brakes on my rudder pedals were still not working, before I had to shut it down. I did not get a chance to reset the pedal config back to the defaults, but I will try that.

My current plan is to do the 9.1 upgrade and see where that leaves me, then go from there. I sure appreciate all the good advice - I'll report back if/when I get this solved.

Rick108 Guest

Last night I installed the 9.1 update and reset the Pedal calibration back to the default. Everything works fine now. I removed the "show_brake_message" line and now even the "BRAKES" messages make sense. I guess I'll assume this was a bug in the 9.0 code that was fixed by the upgrade. I really appreciate all the helpful information - keep up the good work!

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

Glad you got it fixed 👍

Pro Member Trainee
Greyson Bassett (greystone) Trainee

Would like to add my name to the roster of pilots with problem CH pedals and brakes when sensitivities are adjusted in the sim. I too solved the issue with resetting to default in the FS Settings section. Went into CH Control Manager and tweaked them to my liking. The FS pedal default sensitivities are a tad touchy for me.

Pro Member Chief Captain
RadarMan Chief Captain

Rick108 wrote:

Last night I installed the 9.1 update and reset the Pedal calibration back to the default. Everything works fine now. I removed the "show_brake_message" line and now even the "BRAKES" messages make sense. I guess I'll assume this was a bug in the 9.0 code that was fixed by the upgrade. I really appreciate all the helpful information - keep up the good work!

Good to hear all is well and thanks for letting us know what worked. It'll help others.

Radar

Rick108 Guest

Interesting sidenote: after installing the 9.1 update, I had a new problem - my throttle would only adjust RPMs between about 1500 and 2100, no more idle and no more full RPMs (in both the C172 and PA2😎. Fooled with that a while, then finally reset the Yoke calibration back to default and the problem went away. So what is up with this "default" calibration? When I go through the calibration, I see the full range of raw values, from 0 to 255, and after going back to "default", I still see the same range of values. So what is it changing?

greystone wrote:

Would like to add my name to the roster of pilots with problem CH pedals and brakes when sensitivities are adjusted in the sim. I too solved the issue with resetting to default in the FS Settings section. Went into CH Control Manager and tweaked them to my liking. The FS pedal default sensitivities are a tad touchy for me.

Greystone, you mentioned that you tweaked the settings using "CH Control Manager" - what is that? I don't like the default pedal settings either, they are much more touchy then the real PA28 I am learning in, but I am afraid to adjust them with MSFS now after my previous problems and reading these posts...

Pro Member Trainee
Greyson Bassett (greystone) Trainee

Rick, CH Control Manager is a software program that allows you to make very precise adjustments to your CH yoke, stick, pedals, throttle-- whatever you have installed. You can download here:

http://www.chproducts.com/retail/tech_control_manager.html

All times are GMT Page 1 of 1

Related Questions