Fly Away Simulation
SearchSearch 

Installing from WOA1 installer to FSX

Pro Member Trainee
downwind03 Trainee

Although I have no problem installing A1 Aircraft/Flight Plans to fs9 using the WOA1 Installer, I find the error 'Unhandled Exception has occurred' pops up when I hit 'Install' to FSX.

Both my fs9 and FSX are installed on a dedicated 'D' drive.........I use the 'C' drive for all ancillary folders relative to both game versions.

Therefore, I hold the WOA1 Installer in a dedicated folder together with downloaded Zip files from AVSIM et al. Project A1 similarly together with the necessary TT Tools and A1 Downloads. I have no problem with PA1.

Any help out there?.......please

UPDATE
Further to the above I've now manually extracted WOA1 Winzips which are now held in FSX but without air-files. What do I now do to get these flights flying? As you can see I'm a graduate from fs9 to fsx......it 'aint quite the same! Help please.

Pro Member Chief Captain
Tailhook Chief Captain

I too have both FS9 and FSX, though currently my new FS9 install is still without any 3rd party AI traffic.
Having said that, I have in the past extensively used the WOAI installer and packages for FS9 and again for FSX. Never had any problems.

I think WOAI had to update the installer for FSX in the past. Make sure you are using the latest version, it WILL handle both, FSX and FS9.

I just extracted a WOAI package manually to see what's inside the .zip file -- a ReadMe and an .ENC file. Obviously moving the .ENC file manually into the Airplanes folder won't do anything, at least not create an .AIR file. I doubt that it will create anything else e.g. model- sound- texture folders and aircraft.cfg file.

In conclusion there is really no difference whether you install those packages into FS9 or FSX by way of the installer (with the exception of the target directory of course). I can only guess that you are now using Vista which may or may not require EXTRA coaxing.

Revisiting the Installer Documentation I found the following:

Extract package or Manual Install:

If you want to do a manual install just check the check box and select the output directory. The manual installation is nothing more then an extraction of all the files to a user defined directory.

...A manual install will only extract the contents of the WOAI package to the selected directory. You have to do the install in FS manually.
In this mode also multi select of packages will work.
Also the installer will not add this airline to the list of installed airlines and no uninstall is possible.

I gather you might have tried this method, I never have because of this "no uninstall" warning. Sorry can't help you. If you figure it out, please share the solution with us.

Pro Member Trainee
downwind03 Trainee

Nice to have your help again 'Tailhook'.......we met over your bar a few times when I was having problems installing a Britten Norman (BN-2) to my fs9. You solved everything at that time with your usual great clarity, but sadly this one looks as if it's going to involve entering my Systems Registry which I'm not qualified to do at this time.

Briefly........Firstly, I deleted all the WOA1 generated packages in SimObjects/Airplanes.........checked to ensure I was using the updated WOA1 Installer for fs9/FSX and that .NET Framework 2 was also installed.

I ran a test with a WOA1 package but I'm back to square 1 which translates to......'System.IO.FileNotFoundException: Could not load file or assembly 'ICSharpCode.SharpZipLib, Version=0.84.0.0, Culture=neutral, PublicKeyToken=1b03e6acf1164f73' or one of its dependencies. The system cannot find the file specified.' etc etc.

All this stuff ends with.....'WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.'

Since I'm not a fully paid-up member of the planet from where this originated perhaps there is someone who could join us at the bar and provide enough technical know-how so I could make some progress.

I'm not working with Vista......still with Windows XP.

I've already backed-up my Registry so I'm all set to go where braver folk than I have been before.
[/b]

Pro Member Chief Captain
Tailhook Chief Captain

downwind03 wrote:

....we met over your bar a few times when I was having problems installing a Britten Norman (BN-2) to my fs9.

Sorry, I didn't recognize you, your username sounded familiar but the postcount didn't make any sense.

To your problem: The message 'WRN: Assembly binding logging is turned OFF. appears to be in connection with SharpZipLib, a .zip file extraction tool/application from what I can make out. If you are indeed using this tool to extract your .zip files, try the Windows XP tool instead and see if it works. You obviously have used some kind of extraction tool successfully in the past, but perhaps you have in the meantime installed SharpZipLib and you're either missing a .dll file for this or one conflicts with the other.

Before we get too carried away with the philosophical aspects of our beloved Windows OS, I'd suggest to just try the integral tool as mentioned above. I usually right-click on the .zip file, select Extract All... and take it from there.

If this doesn't work, I can recommend 7-Zip Arrow http://www.7-zip.org/ --- brilliant tool and easy to use.

My theory in a nutshell is that the WOAI installer won't recognize your .zip folders because whichever .zip tool you're using by default is missing a .dll file. By installing a NEW 3rd party tool such as 7-Zip, I'm hoping that the missing .dll file will be replaced or the conflict resolved in some other way.

P.S.: I had a look for this registry value [HKLM\Software\Microsoft\Fusion!EnableLog] in my Registry but don't seem to have it, which led me to the conclusion that it has to do with an application I do not have - but you do. I am speculating though.
However, if you want to have a look, you should find it by clicking on your Start button, next Run..., now type "regedit" without the quotes, hit Enter -- now your Registry Editor is open and you can navigate the following path:

HKEY_LOCAL_MACHINE
--SOFTWARE
----Microsoft
------Fusion

I do have the Fusion folder but nothing inside that resembles !EnableLog] (DWORD) to 1

Sooo... if I say another word I'll start confusing myself and that won't help you either... see how you go, I'll be keeping an eye on this topic. Hack

Cheers!

Anyone else? Traches, Michael et al where are you...

Pro Member Trainee
downwind03 Trainee

Many thanks for the lead to 7-Zip which I've tried. Sadly it didn't help. I'm left with the core of the same problem viz. 'WRN: Assembly binding logging is turned OFF.
To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.'

I braved a 'new world' and entered the mysteries of my Registry (Windows XP) and have spent the last 24 hours sleeping, eating and what was left, searching the web for an understanding of how to TURN ON the Assembly binding logging.

I'm sure this is one helluva' bore but I guess I'll persist until the problem is resolved.

Meanwhile, I remain puzzled why WINZIP, 7-Zip et al deal perfectly well with fs9 and WOA1, but not with the demands of FSX!!

Pro Member Trainee
downwind03 Trainee

I thought I should let you know that since essentially this is a WOA1 problem I've sent them the complete script of the error as it comes up in the WOA1 Installer. This was at their request via their Forum. Of course I'll share with you any news as it arrives.

Pro Member Chief Captain
Tailhook Chief Captain

This is appreciated. In fact I was going to suggest the WOAI support center in my previous post had it not been for the SharpZipLib...

You are not mentioning it now so I assume you're unaware of its existence on your system. I meant to tell you yesterday to uninstall SharpZipLib first of all unless you absolutely need it but forgot... sorry, my bad.

This will be interesting. I'm curious to say the least as to what the WOAI boys will dig up.

Pro Member Trainee
downwind03 Trainee

Cracked it 'Tailhook'. It was so simple I still can't believe it. All it took was the deletion of a WOA1 Installer I'd put on my Desktop.....a download of the Installer again to a 'Downloads' folder where all my downloaded WOA1 packages are kept..........run the Installer from this folder.....go through the on-screen directions........and it worked.

I've since told the guys at WOA1 what I'd done to solve the problem and suggested that the Installer will work only if it is in the same folder as the Packages.

They say 'No'.....it should work wherever one puts the Installer.

Well...as you may guess, I 'aint arguing----I now have the Packages in my FSX....they're flying and that will do for me.

Incidentally, the SharpZipLib dll. is integral with the Installer so I don't know what would have happened if I'd unistalled it. I couldn't find it anyway.........perhaps I misunderstood you?

Yet again....many thanks for your help and patience.

Another round on me!

Pro Member Chief Captain
Tailhook Chief Captain

That's great news Downwind and thanks to your feedback, I too have discovered a thing or two. Very Happy

...but, curiosity is a vicious demon I happen to be burdened with. When the WOAI guys say that the installer should work from anywhere it's convenient, I would have to concur. From the little I understand of these matters, whenever you can run a small "program" such as the WOAI installer from its folder without the need to install the actual program itself, the .Net framework is required.
In my case, I've always kept the WOAINS on my desktop for easy access and never experienced mishaps.

downwind03 wrote:

Incidentally, the SharpZipLib dll. is integral with the Installer so I don't know what would have happened if I'd unistalled it. I couldn't find it anyway.........perhaps I misunderstood you?

Perhaps you did but that's inevitable. It's just as likely I misunderstood you. From yor previous post: Could not load file or assembly 'ICSharpCode.SharpZipLib, Version=0.84.0.0 ::This obviously points to SharpZipLib which, according to Google, appeared to be an Open Source program I thought you might have messed with. It never occurred to me that I might have a SharpZipLip.dll on my own hard drive.
Your statement that the "SharpZipLib dll. is integral with the Installer" is almost correct... it's a positive almost as it compelled me to distinguish between SharpZipLib.dll and ICSharpCode.SharpZipLib.dll -- the latter being the one residing in the WOAINS, the former being a part of EditVoicepack22a.

Sooo... your warning message was pointing in the right direction all along -- had I bothered to look inside the WOAINS folder I would have seen it, what's more, the .dll filename even includes the version number i.e. 0.84.0.0 Shocked

Well, we live and learn. I still concur with our WOAI experts though, you should be able to run the WOAINS from anywhere. The fact that replacing your "old" WOAINS with a new one rectified the problem does point to a probable corruption of that pesky .dll file. It happens, and when it does, I for one tend to look everywhere except the place where I should look first: Right in front of my nose Very Happy

Happy days and thanks for sharing the problem's remedy with us Cheers!

Pro Member Trainee
downwind03 Trainee

What would we do without a search vehicle as good as Google. On the other hand I always seem to end up with so many leads that I need Google to understand what I've been 'Googled'! One damn' Google after another.

So......SharpZipLib.dll and ICSharpCode.SharpZipLib.dll......oh what the hell!!

Anyway, there's one more play before time is called on this one. Here it is.......a paste job from my last post to WOA1

'One further thing.......just now I tried the Installer from my Desktop and as you said it would.........it worked. Therefore, I believe the only remaining reason why I've had so much trouble is because of NET.Framework 3.5 which I originally installed a few weeks ago. What I didn't tell you was that I uninstalled this programme only yesterday BEFORE the Installer began to work for me which means possibly that WOA1 isn't compatible with 3.5 but only with NET.Framework 2.

I mention this for what it is worth'

I tell you where I'm not going today......I'm not going to ask Google why WOA1 may have a problem with NET.Framework 3.5. I'm done......I need a drink 'Tailhook'.
[/i]

All times are GMT Page 1 of 1

Related Questions