SearchSearch 

Fatal Error

Pro Member Trainee
Nelson Robison (photoshock) Trainee

Why am I getting a 'Fatal Error occurred' message while starting the program? It will not even get to the start page and I am frustrated with the whole shooting match.
Does anybody have any clue as to why this is occurring? FSX with Acceleration package worked fine this morning, now I cannot even get to use the Sim. Something is seriously wrong with the program, I have a stand-alone 512 meg. video card and a quad core processor in my computer with NVidia, and the video card is Geo-Force.
Please help!!!!

18 Responses

Pro Member Chief Captain
RadarMan Chief Captain

Delete the log file and it should start.

If it doesn't delete the FSX.cfg file and the Sim will build a new one.

Radar

Pro Member Trainee
Nelson Robison (photoshock) Trainee

Thanks RadarMan, you always have good suggestions and ideas for the operation of Flight Sim X.
I don't know if people really understand the depth of your knowledge but I do and I truly appreciate all the help you give and are capable of giving through the forums.
Thanks so much again for all the help, you're the best!

Photoshock

Pro Member Trainee
Longhaul4441 Trainee

Radarman, I noticed that in the FSX Tweak Guide, that my fsx.cfg doesn't list everything that the author's does. But I don't know if he's using Acceleration or SP1. I can list what mine says and maybe you can tell me if yours is about the same as I know you have addons and additional a/c installed. Maybe you could give some pointers as to what is missing. Also check out the other post on Falal Errors for what I have found concerning that issue. The only thing I changed in the cfg is I forced FSX to use all 4 processors as it wasn't doing that by itself.

Here it is:

[SOUND]
AmbientUIMusicVolume=-6.000000
SOUND_FADER1=0.730000
SOUND_FADER2=0.730000
SOUND_FADER3=0.720000
SOUND_FADER4=0.870000
AmbientUIMusic=FSX02
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
UISound=1
AmbientUI=1
PrimaryDevice={00000000-0000-0000-0000-000000000000}
VoiceDevice={00000000-0000-0000-0000-000000000000}
[Display]
ChangeTime=4.000000
TransitionTime=4.000000
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
BLOOM_EFFECTS=1
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=300
UPPER_FRAMERATE_LIMIT=44
WideViewAspect=False
ForceFullScreenVSync=True
[Main]
User Objects=Airplane, Helicopter
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
Maximized=1
Location=320,117,1360,893,\\.\DISPLAY1
HideMenuNormal=0
HideMenuFullscreen=0
FIBER_RATE_TIME_FRACTION=0.99
ProcSpeed=8013
PerfBucket=7
[PANELS]
IMAGE_QUALITY=1
QUICKTIPS=1
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
DEFAULT_VIEW=0
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherServerAddress=fs2k.zone.com
WeatherServerPort=80
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=2
DownloadWindsAloft=1
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=3
DETAILED_CLOUDS=1
CLOUD_COVERAGE_DENSITY=7
THERMAL_VISUALS=0
[DISPLAY.Device.NVIDIA GeForce 9800 GTX/9800 GTX+.0]
Mode=1680x1050x32
TriLinear=1
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[GRAPHICS]
SHADER_CACHE_PRIMED=1693500672
TEXTURE_MAX_LOAD=1024
NUM_LIGHTS=8
AIRCRAFT_SHADOWS=1
AIRCRAFT_REFLECTIONS=1
COCKPIT_HIGH_LOD=1
LANDING_LIGHTS=1
AC_SELF_SHADOW=1
EFFECTS_QUALITY=2
GROUND_SHADOWS=0
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
SHADER_CACHE_PRIMED_10=1693500672
D3D10=0
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[SlewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=1
[USERINTERFACE]
ShowAllACPaintSchemes=1
SelectAircraftManufacturer=All
SelectAircraftPublisher=All
SelectAircraftType=All
PageID=1
OpenATCOnCreate=0
SHOW_MISSION_CAPTIONS=0
PAUSE_ON_LOST_FOCUS=1
PROMPT_ON_EXIT=1
SITUATION=C:\Users\Joseph Jr\Documents\Flight Simulator X Files\Startup
Map_Orientation=2
[RWW_WEATHER_MAP]
SHOW_AIRPORTS=0
SHOW_VORS=0
SHOW_NDBS=0
SHOW_APPROACHES=0
SHOW_INTERSECTIONS=0
SHOW_VICTOR=0
SHOW_JET=0
SHOW_AIRSPACE=0
SHOW_FLIGHTPLAN=1
SHOW_WEATHERSTATIONS=1
SHOW_WEATHERSYSTEMS=1
SHOW_DATATAGS=1
SHOW_TERRAIN=1
[ATC]
ShowATCText=1
COMM_MSG_NONE_COLOR=FFFFFFFF
COMM_MSG_ATC_USER_COLOR=FFB6FFB6
COMM_MSG_USER_ATC_COLOR=FFFFD21B
COMM_MSG_ATC_AI_COLOR=FF00FF00
COMM_MSG_AI_ATC_COLOR=FFFF7840
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
PilotVoice=0
[PointOfInterestSystem]
CycleSetting=0
[SCENERY]
LENSFLARE=1
DAWN_DUSK_SMOOTHING=1
IMAGE_COMPLEXITY=3
[TrafficManager]
AirlineDensity=15
GADensity=15
FreewayDensity=15
ShipsAndFerriesDensity=35
LeisureBoatsDensity=35
IFROnly=0
AIRPORT_SCENERY_DENSITY=3
[TERRAIN]
LOD_RADIUS=4.500000
MESH_COMPLEXITY=70
MESH_RESOLUTION=19
TEXTURE_RESOLUTION=24
AUTOGEN_DENSITY=2
DETAIL_TEXTURE=1
WATER_EFFECTS=5
[AContain]
ShowLabels=1
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[INTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=0.000000
Torque=0.000000
GyroEffect=0.000000
CrashTolerance=0.000000
General=0.000000
UnlimitedFuel=True
TrueAirspeed=False
AutoCoord=False
RealMixture=False
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=True
AutoTrim=False
AllowEngineDamage=False
[SIM]
SYSCLOCK=1
[STARTUP]
DEMO=0
SHOW_OPENING_SCREEN=1
STARTUP_DEMO=
LoadWindow=1
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=1770
[Misc]
Com_Rate=7
[JOBSCHEDULER]
AffinityMask=14
[AccelerationPack]
ControlsFirstRun=0
HomePageFirstRun=0
[Trusted]
C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\GAUGES\BoeingGeneric.DLL.chnqqiczaqcrrnuznqezirtwlucotnqublucnuht=2
C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\GAUGES\Magnetic_Compass.DLL.oiociltcochabbhcaqikhbebikqrztbhwautbkqr=2
[MAPVIEW_MAP]
SHOW_AIRPORTS=1
SHOW_VORS=1
SHOW_NDBS=1
SHOW_APPROACHES=1
SHOW_INTERSECTIONS=0
SHOW_VICTOR=0
SHOW_JET=0
SHOW_AIRSPACE=1
SHOW_FLIGHTPLAN=1
SHOW_WEATHERSTATIONS=1
SHOW_WEATHERSYSTEMS=1
SHOW_DATATAGS=1
SHOW_TERRAIN=1
show_flight_history=1
[MULTIPLAYER]
condAccoutPassword=0
VoiceVolume=1.740000

Pro Member Chief Captain
RadarMan Chief Captain

I don't know what tweak guide you mean but most of them were put out soon after the Sim came out.

No one has the same cfg unless they didn't fly yet.
Many add-ons change it so telling what you missing would be difficult.

Radar

Pro Member Trainee
Longhaul4441 Trainee

ok, was worth a shot. I'm getting to the point of grasping at straws here. Almost ready to give up and uninstall it all together and install X-Plane 9.41 (which by the way, I have no problems running).

Pro Member Chief Captain
RadarMan Chief Captain

You reinstalled Windows, ran all the updates, installed FSX and Acceleration and you get the error.

Something you are installing is causing it, or it's hardware related.

Running any beta software?

Radar

Pro Member Trainee
Longhaul4441 Trainee

no no beta software. Only thing installed with vista is:

CCleaner v2.27
Foxit reader
FSX w/acceleration

I'm wondering if the 9800 GTX/9800 GTX+ maybe the problem. I have been wanting a new video card, but would hate to spend several hundred on a new one only to find out that its not the problem. I don't even have AV installed yet. Foxit reader and CCleaner were installed after the last error. So like I said before...I'm at a loss as this is the same setup I used before. Let me see if NVidia has any new drivers that I can get. And I wonder if I disable the MB onboard video which is ATI if that would help.

Pro Member Chief Captain
RadarMan Chief Captain

If your on board card is ATi you should have replaced it with ATi, there may be a conflict.

Here is the way.

http://www.techspot.com/vb/all/windows/t-21852-How-do-I-disable-my-integrated-video-card.html

:radarA:

Pro Member Trainee
Longhaul4441 Trainee

Well after disabling on board video and uninstalling the drivers for it, I updated the MS Vicual C++ 2005 and 2008 with SP1 from MS as windows update didn't giva any updates for them. Nvidia had a new driver out this month that was installed......so far so good. going from KCAE to KBAD, and right now over Birmingham, AL after 45 minutes, with 1hr 12 min left. If this goes well I'll post, and then go for a longer flight with pre installed FSX a/c. If that goes well I'll post that also. Then I'll start my addon installation process and post results. I won't do one and post, be more like 5-10 then post, with over 100 addons the post would be too damn long to read. Wish me luck 😀

Pro Member Trainee
Longhaul4441 Trainee

Ok we just had a 2.6 hr flight with no problems. Here is what I did:

Erased fsx.cfg and let fsx rebuild it.
increased fps from 20-40

and it's working so far. I think I can start to install addons now. Will keep you up to date on how it goes. But I think I'm gonna call it quits for tonight. 😀 😀 😀

I think the fatal errors lie with the video cards and the drivers. If you have too many high end scenery addons (like I did) and a low frame rate it might have put too much load on the video and caused FSX to quit working. But this is just a theory at this point.

Pro Member Chief Captain
RadarMan Chief Captain

Hardware not software.
I thought you built your own machine that's why I never imagined an onboard car.

Radar

Pro Member Trainee
Longhaul4441 Trainee

lol, I did build it. This si the exact same setup I had before when FSX ran without a hiccup. I am getting ready to run Crossfire in a few weeks by adding 2 5870 cards, and removing the 9800 GTX+. I have installed a couple of addons and so far no problems. Why this reared it's ugly head now is something I can't figure out. I did have comodo installed with FSX last time, but had Norton installed with time. I put comodo on also this morning too. So it may have been a combination of things, but if all goes well I think we have fixed the issue.

Pro Member Chief Captain
RadarMan Chief Captain

If your going CrossFire for FSX it doesn't accept it or SLI.

Radar

Pro Member Trainee
Longhaul4441 Trainee

not for FSX, but a faster video card wouldn't hurt. And still no errors, I believe we fixed that problem (fingers crossed)

Pro Member Trainee
Longhaul4441 Trainee

Ok, install Abacus Flight Deck 5 for FSX and got a Fatal Error sitting at the terminal. Uninstalled it, deleted FSX.cfg and scenery.cfg and let FSX rebuild them. Started a flight from KCAE to KGFK (Columbia Metro to Grand Forks Intl).....and as I write this another Fatal Error. I'm done with FSX, I'm gonna do exactly what MS did, throw it out in the trash. I'm installing X-Plane 9 and never going back to FSX Evil or Very Mad

Pro Member Chief Captain
Tailhook Chief Captain

Abacus FD 4 and or 5 have their quirks as they were updated for FSX during a time of great upheaval, namely the emergence of FSX SP1, SP2 and Acceleration.
Because of this often (not always) it is almost impossible to uninstall Abacus FD completely - that is my experience anyway.

FSX on its own can be very problematic even without 3rd party add-ons. No need for me to elaborate, just visit several of the larger flightsim forums and you'll find that the FSX sections are full of Error Queries, questions about frame rates, 3rd party aircraft and sceneries which never have and never will be developed for FSX (though an abundance of those exist for FS9 and even previous versions of MSFS), and pleas for tweaks to get FSX to perform.
Wander into the FS9 sections and you'll find it's all about enjoyment and sharing of experiences.

Many of us who bought FSX when it was first released have gone back to FS9. Yes it lacks 'certain' dormant potential compared to FSX but what's the use of that if it cannot be raised from its slumber?

It is not my intention to discourage you from X-Plane. However, a few bucks will buy you a new copy of FS9.
Having plenty of hard drive space available, I have both FSX and FS9 installed. FSX is there for my own curiosity and experimentation with new "groundbreaking" add-ons -- FS9 is the sim I use for flying and enjoyment. Even now many new add-ons are being created for FS9.

Pro Member Trainee
Nelson Robison (photoshock) Trainee

Tailhook, I am still experiencing the same problems that I had even before I had to reinstall Windows and now am considering buying a new video card and more memory. FSX is a resource hog that just eats memory and graphics like it's going out of style.
I am the original poster of this problem and have yet to come up with a solution for this seemingly insurmountable problem, I do not want to give up on FSX but am at the point of no return.
My next step with a 512 Meg Stand alone video card, meaning it does not give
up any resources to the motherboard, and 2 GHz memory is to either get 4GHz memory with a 1 GiG video card and then see if this program works. Any other programs even graphics intensive programs run just fine on my computer, yet FSX will not and does not run properly.
It's either that or do the same as you and buy a new copy of FS2004 and run that or buy an almost complete new system?
Any suggestions? Please post or private message me at photoshock on Fly Away Simulation.
Thanks everyone for all the help!!!!!!

Pro Member Chief Captain
Tailhook Chief Captain

PM is in your inbox 🙂

All times are GMT Page 1 of 1

Related Questions