Running FS2004 on Windows7

Pro Member First Officer
RichT First Officer

I previously ran FS9 on Windows XP but am now transferring over to Windows7.

In XP I was advised to modify the system registry to stop Windows updating my files last access date on files every time they were read. I did this and it greatly improved the performance.

Does anyone have experience with Windows7 and can advise if I need to do this again?


3 Responses

Pro Member First Officer
Pete (pdegraff) First Officer

How do you modify the registry to accomplish what you said?


Pro Member Captain
Welshflyer Captain

Hi RichT, i don't know about modifying the system registry in W7, but i did have a few issues running FS2004 in it when i had it (i've now gone back to XP). W7 Premium would'nt run FS2004 properly and apparently it would run on W7 Pro and Ultimate because they have a "run this programme in XP" mode,but i was informed this was like running a system within a system and reduces performance!
All i know is FS2004 would'nt run as i wanted it to on the W7 i had!

Pro Member First Officer
RichT First Officer

Since going over to W7 it has been an expensive transition. Firstly I had to change the wireless LAN card, sound card and graphics cards, as none of these would work properly in W7.

I previously had GE ProII and Active Sky 6.5, Ultimate Traffic and other add-on programmes - yet again these had to be replaced as they would not work. I now have to check with every add-on if it will work in W7.

That said however I am starting to see the improvement. I now have a clean FS9 which I am building up slowly still, but the flights I have run so far have been a lot better, with sharper images and smoother running (could partly be due to the new graphics cards as well!).

Pete, with regards to the registry in XP, I did the following to improve performance:

From the Windows desktop:
Press START then RUN
Browse to:hkey_local_machine\system\current controlset\control\filesystem
add DWORD NtfsDisableLastAccessUpdate
Change value to 0X1

Now reboot your system.

All times are GMT Page 1 of 1

Related Questions