Fly Away Simulation
SearchSearch 

Rome-Naples Mission

Pro Member Trainee
Nelson Robison (photoshock) Trainee

Again, I am not a newbie to the flight sim community, and yet when I have tried the last two times to fly the Rome-Naples Mission, just as I was about to land the plane sped up and I could not land the plane.
I had full flaps, spoilers set to full and was at 140 kph, and less than 1000 above the runway when this occurs.
Is something wrong with FSX? I have flown this mission hundreds of times and the last two cannot seem to land the plane, Am I doing something wrong? 😕 😕

Pro Member Trainee
ehuang6 Trainee

This is a bug with the A321 used in this mission. I suggest you go to the overhead panel (press SHIFT 5) and turn off the A321's flight controls. On the lefthand side in the middle, you should see a FLT CTRL section. Press the 3 (or 4, can't remember) squares, which should turn them to OFF (they will say OFF). This should get rid of the acceleration and sluggish control problems.

Hope this helps!

Pro Member Trainee
Nelson Robison (photoshock) Trainee

Thanks for the advice, like I said, I've flown this mission hundreds of times without a problem. It's only in the last two times that I have had this occur.
Thanks for the information and the suggestions.
It restores my faith in all the flight sim community.

Pro Member First Officer
lionlicker First Officer

Forgetting to turn off the autothrottle maybe??? 😂

Pro Member Trainee
Nelson Robison (photoshock) Trainee

LionLicker, I do not even use the autothrottle on this mission.
I fly strictly by wire and do not use the auto-pilot or auto-throttle.
I finally found a plane that would fly the mission, the Boeing 737 and not the Airbus A321.
I just wish that there was some way to fly this mission with the A-321 but after 5 attempts, I gave up and switched the planes and it worked fine.

All times are GMT Page 1 of 1

Related Questions