Fly Away Simulation
SearchSearch 

Good frame rates but still choppy.

Pro Member Captain
Sam (SamIntel) Captain

This problem just started when I got my new PC. I am getting good frame rates, I have them locked at 20 and I'm getting about 19.6, but the weird thing is they change. I'm getting 19 FPS then it drops to 3 for a sec then goes back up to 19, it keeps doing this like every 2 seconds.It is like when you are getting bad frame rates, it's hrad to when when it dose this. It seemd like it only dose this when the weather in not Clear, but I'm not sure.

Please Help.

Intel Pentium 4 3 GHz
512 MB RAM
256 MB video card

Pro Member First Officer
SoCalRick First Officer

SamIntel wrote:

This problem just started when I got my new PC. I am getting good frame rates, I have them locked at 20 and I'm getting about 19.6, but the weird thing is they change. I'm getting 19 FPS then it drops to 3 for a sec then goes back up to 19, it keeps doing this like every 2 seconds.It is like when you are getting bad frame rates, it's hrad to when when it dose this. It seemd like it only dose this when the weather in not Clear, but I'm not sure.

Please Help.

Intel Pentium 4 3 GHz
512 MB RAM
256 MB video card

Hi Sam,

Sounds like a texture loading issue. Load the sim and go to SETTINGS and Display. Make sure that there is NO check mark in the box next to Extended Terrain Textures.

Another thing to look at it in your fs9.CFG file.

Go to Start>Run and type %appdata%\Microsoft\FS9 and click OK. This will take you right to the hidden folder. Open your fs9.CFG with Notepad, then search for this:

[DISPLAY]
TEXTURE_BANDWIDTH_MULT=40

Try a higher value like 400, and if no improvement then try lowering it till you hit the sweet spot (try halfing the value each time until you reach a place that stutters less than it is now).

It would help if you posted your display setting screens also.

Rick

Pro Member Captain
Sam (SamIntel) Captain

Ok, I unchecked the Extended Terrian Textures box. I have every thing maxed out in the Display settings. Exept in hard ware, I run the resolution at 1152x864x32, Anti-aliasing is not checked but it is checked in the video card controls. MIP Maping is set to 5, Hardware render lights are set to 8, and Global Max Texture Six is set to Massive.

I havn't tried to edit the cfg file yet, I'm going to go see if unchecking the Extended Terrian Textures box did anything.

Pro Member Captain
Sam (SamIntel) Captain

Ok, that didn't work. I'll go try the other thing with the CFG file.

Pro Member First Officer
SoCalRick First Officer

SamIntel wrote:

Ok, I unchecked the Extended Terrian Textures box. I have every thing maxed out in the Display settings.

With a 512MB of RAM I'd be a bit more conservative on the display settings, perhaps lowering or turning off autogen for one. For that size RAM the things that will you hardes will be clouds, traffic, and water effects.

You should also try going to your weather settings from Create a Flight, clicking on User-defined weather, then the customize weather button, and setting visability to 30 miles and slide clouds down to zero.

Set you sound quality to low if it's not already.

Exept in hard ware, I run the resolution at 1152x864x32, Anti-aliasing is not checked but it is checked in the video card controls.

Good. How about AF (anisotropic filtering)? This kills frames so I'd turn it down in your card settings. Play with AA by pausing FS9 and bringing up your gfx card options, and trying different settings, then noting the impact on frames.

MIP Maping is set to 5, Hardware render lights are set to 8, and Global Max Texture Six is set to Massive.

I'd recommend you try MIP=4, HRL=5, and GMTS-High.

I havn't tried to edit the cfg file yet, I'm going to go see if unchecking the Extended Terrian Textures box did anything.

It's worth experimenting with, but it's very subjective (everyone seems to get different results) so be prepared to reboot FS9 several times, remembering that fs9.CFG isn't saved untill you properly shut down the sim.

If you try everything and still have stutters, I suggest you shut down FS9 and rename your fs9.CFG file to fs9.CFG.bak so as to force the sim to rebuild the config file. Often times this will kill the stutters, then you can experiment with boasting settings from that baseline.

Rick

Pro Member Captain
Sam (SamIntel) Captain

I changed the TEXTURE_BANDWIDTH_MULT=40 to =400 and it seems to be running smothly now. In the video card settings I have Anti-aliasing set to 4x and anisotropic filtering set to 8x, RM recomended these settings, but I'll play with the anisotropic filtering. Any thing els I should do?

Pro Member First Officer
SoCalRick First Officer

SamIntel wrote:

I changed the TEXTURE_BANDWIDTH_MULT=40 to =400 and it seems to be running smothly now. In the video card settings I have Anti-aliasing set to 4x and anisotropic filtering set to 8x, RM recomended these settings, but I'll play with the anisotropic filtering. Any thing els I should do?

It's running smoothly now so I'd leave it alone, lol. Perhaps make a backup of your fs9.CFG so you have something to fall back on in case of an "oops" later. As to your gfx card settings, seems like you have a good card so following Radar's advice makes sense.

Sounds like you're in pretty good shape now. I can't emphasize enough what a difference a properly defragmented drive and defragmented RAM can make. If you've only used the built-in defrag applet I'd suggest downloading the O&O demo from download.com, and doing a COMPLETE/Modified type defrag. For RAM defrag I like Ken Salter's FsAutoStart.

Rick

Pro Member Captain
Sam (SamIntel) Captain

ok, thanks Very Happy

All times are GMT Page 1 of 1

Related Questions