SearchSearch 

SP2 & FSX

gazpode Guest

Does anybody know wheather the full version of fsx requires windows XP service pack 2?

I know the demo does.

Trouble is i tried installing SP2 on my dad's mc and messed the mc up totally to the point where we had to restore the mc back to day 1.

If fSX does require Sp2 then I shant be buying it!

1 Responses

Pro Member Captain
Sean (SeanGa) Captain

Yes, it requires either Windows XP SP2 or Windows Vista

All times are GMT Page 1 of 1

Related Questions