Doom 3 problem

Pro Member Chief Captain
Alex (Fire_Emblem_Master) Chief Captain

Hello. I'm at my wit's end with this, and am going to call tech support tomorrow if I dont get this worked out. Maybe someone can help.

Ok, this happens after my PC has been logged on as me for a while, usually after about 45 mintes. I go to load up Doom 3, and after it gets to the part where it says "Initializing Menu" I hear the sound of the "ID" Cutscene, where you see that mechanical heart, But it does not show it, it just says initialyzing menu, and stays like that. FOREVER. I have no idea what to do, and i tried re-installing and whatnot as well.


Oh, I'm running it at the highest detail level, 1024x768

Answers 6 Answers

Jump to latest
Pro Member Chief Captain
RadarMan Chief Captain

If it's freezing at that moment I wonder if that very graphic intensive and overheating is the problem.
Try doing it with the side of the case off, and if you have a fan to point at it do it.
Don't do this to long or often.
If it works then you will have to add a fan or two to your case, easy and cheap.
I imagine that you do have the latest drivers.


Pro Member Chief Captain
Alex (Fire_Emblem_Master) Chief Captain

Sweet! Thanks Radarman!

Pro Member First Officer
jelami First Officer

Have you been able to play it at all? What I am asking is was it working and now it has stopped?
This is a great game, and I am running it on a 1.5 mgh cpu with 1 gig ram and a Radion x800 pro video card without any problems. by the way, I have enough fans on my PC to cool Miami.
2 in front, 2 in back, 1 on the power supply, 2 on the motherboard and 1 on the video card. Oh yeah, and a big one on me. 😀

Pro Member Chief Captain
Alex (Fire_Emblem_Master) Chief Captain

yeah, it worked, i beat it, then it started this crap when i started trying to make a mod for it. I'ts possible the mod hosed it up, but if i uninstalled and reinstalled it, why would it still do that?

And, it only does this once, then I turn off my pc manually, then turn it back on, and it works fine

Pro Member First Officer
jelami First Officer

It is possible that when you uninstalled, that it left some tracks. Make sure that all folders are deleted so that you are not picking up some latent files.

Other than that......MAN YOU ARE SCREWED!!!!! 😉

Seriously, good luck

Pro Member Chief Captain
Alex (Fire_Emblem_Master) Chief Captain

No, cause it works fine if it's the first thing I load up...if I wait a while, it does that.

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...