Yoke and pedals

Pro Member Trainee
Splitdog Trainee

I haven't used FSX in a while, and when I tried, the yoke and pedals won't work. They show up in CH manager, and I go to calibrate, it lets me, they work fine and then when I get an aircraft on the tarmac, they quit. Help!!

Answers 2 Answers

Jump to latest
Pro Member Trainee
Splitdog Trainee

I cleaned the inside of dust and let her cool down. i tried again and got farther, but same crap. Yoke quits responding.

Pro Member Trainee
Splitdog Trainee

I found and fixed the problem. My yoke and pedals were plugged into different USB ports than they usually are. I don't know why, but that made a difference. Everything works great now.

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...