CH Products flight sim yoke not working on FSX


So, I recently saved up for a CH products flight yoke and FSX SE. it gets here, I set it up. Then I go into Buttons/Keys to set it up there, and my axis are being controlled by the throttle quadrant. The throttle is Z, the prop is Y, and the Mix is X. I tried setting my axis to my actual yoke in Control Axises and the game is not registering that I am even turning the yoke. I tried going into Calibrate, but still nothing. please help me, I don't think I can go without FSX for much longer!

Answers 2 Answers

Jump to latest
Pro Member Chief Captain
RadarMan Chief Captain

Clean out any software you installed for the CH.
Download and install the latest on this page.

If you continue to have problems contact them.

Before you do any of these "fix's" move your USB from the yoke to another USB connection on your computer.


Pro Member Captain
Ian Stephens (ianstephens) Captain
Ian Stephens is an expert on this topic. Read his bio here.

Hey there,

I understand your frustration with your new CH Products Flight Sim Yoke not working as expected in FSX SE. No worries, we'll get through this together. It appears that there could be an issue with the axis mapping or calibration. Let's go through a step-by-step process to try and resolve this issue for you.

Check the CH Products Control Manager: Make sure you have the latest version of the CH Products Control Manager software installed. You can download it from their official website: Once installed, open the Control Manager and verify that your yoke is detected and functioning correctly.

Reset FSX SE controller settings: In FSX SE, navigate to the Controls menu, and click on the Reset Defaults button. This will restore your controller settings to default, which may help in resolving any incorrect mappings.

Re-map the yoke axis in FSX SE: With your yoke plugged in and the Control Manager software running, head back to the FSX SE Controls menu. Under the Axis Assignments tab, manually set the yoke's aileron, elevator, and rudder axis. Be sure to also assign the throttle, prop, and mixture controls to their respective axes (Z, Y, and X).

Calibrate your yoke: In the FSX SE Controls menu, click on the Calibration tab, and then click on the Calibrate button. Follow the on-screen instructions to calibrate your yoke. Ensure that all axes are responding correctly during calibration.

Test in FSX SE: After you've completed the steps above, load up a flight in FSX SE and test your yoke. Confirm that all the axes and buttons are working as intended.

If the issue still persists after trying these steps, you may want to consider contacting CH Products support directly for further assistance: They should be able to provide more in-depth guidance.

I hope this helps you get your CH Products Flight Sim Yoke up and running in FSX SE. Don't hesitate to reach out if you need further assistance or have any questions. Happy flying!

Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...