Joystick Problem

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

I recently moved the computer from one room to another and had to unplug the joystick and then re-install the drivers that came with it etc. When I tried doing it, I installed the drivers and went to set up the joystick but it isn't recognised. It is a Logitech Wingman Force Feedback 3D and it has a USB connection. I keep getting error message after error message saying that the device isn't plugged in properly though it definitely is Evil or Very Mad

Any ideas ❓

Thanks in advance 😉

Answers 3 Answers

Jump to latest
Pro Member Chief Captain
Greekman72 Chief Captain

There are a lot of things u have to try...I believe that if u have already install the drivers when u plug it again windows xp(is this ur system?)must recognize it.

1)Try from device manager to update drivers.Maybe there it appears a question mark about ur unknown device.

2)Unistall drivers and turn off ur computer.Then start.Windows maybe find ur usb device even though couldnt recognise what kind of device it is then in the small window about usb devices (it appears right down),double click it and try to follow the steps ..u will again ask to install drivers.

3)Try to use it in an altrenattive USB port to ur comp.Sometimes USB ports stack from an internal data error or from a sudenly power pic or from a bad grounding.Dont worry if its something like that,in most of cases the ports resets buy itsef(from cpu) and then works properly.

Let us know the results.There some more things u could do but try these for start.

Greekman72 😉

Pro Member Chief Captain
Jonathan (99jolegg) Chief Captain

Well I tried some of your suggestions and after a while, I decided to use different USB ports that are in the back of the computer rather than the ones on the side of the screen. Other devices don't work in these USB ports that are on the side of the computer so I'm guessing they are a bit screwed up 🙄

Thanks for your help 😉

Pro Member Chief Captain
Greekman72 Chief Captain

The side usb ports has a cable which ends in a 5 or 6 pin connector if i remember well.Maybe this connector has unplugged.Check it if u can.


Still does not answer your question? Ask a new question!

If the question and answers provided above do not answer your specific question - why not ask a new question of your own? Our community and flight simulator experts will provided a dedicated and unique answer to your flight sim question. And, you don't even need to register to post your question!

Ask New Question...


Search our questions and answers...

Be sure to search for your question from existing posted questions before asking a new question as your question may already exist from another user. If you're sure your question is unique and hasn't been asked before, consider asking a new question.

Related Questions

Flight Sim Questions that are closely related to this...