Fly Away Simulation
SearchSearch 

[Microsoft Flight Simulator 2004] Crashes

Guest

Hello,

I've just got a new joystick and I have finally installed mine "Microsoft Flight Simulator 2004", but then the problems started...

First of all, after the successful installation process it wouldn't start at all: just after the splash screen the whole screen would go black and the the crash message would appear. Well, I fixed that by switching off the introduction movie in configuration file (as M$ support suggested me). Yes, the game started, but I was immediately thrown into a cockpit of Cessna at some airport. Ok, not a big problem, I can use Alt menu. I was almost happy, before I realised that a lot of stuff isn't working ("Lessons", "Select Flight..." and so on). The game just crashes (but this time with a message with error sending buttons "Don't send" and "Send <...>"), that's all.
I've tried reinstalling game for few times, but still -- no luck. And the same madness is happening to both 9.0 and 9.1.

The system: AMD Sempron 2400+@2800+, 512 MB DDR400, GeForce 6600 128 MB 128-bit, Windows XP Professional with SP2 and all the updates (clean, for sure), DirectX 9.0c. All the drivers are working fine (this system is up for a long time and it's the first game I have problems with).

What the hell is happening here?

Thanks in advance.

P.S. Do not suggest reinstalling the OS.

Pro Member Chief Captain
Greekman72 Chief Captain

Do you have a legal version of FS9 or a copy one?

Guest

Greekman72 wrote:

Do you have a legal version of FS9 or a copy one?

Legal, of course. Wink

Pro Member Chief Captain
Greekman72 Chief Captain

Ok Wink .

If it is i will suggest to unistall-clean up your VGA drivers and install the update ones.It also looks to me like some files has been corrupted or missing but before we talk about it check your VGA drivers and let us know how will it goes after you update them.

Pro Member Chief Captain
CrashGordon Chief Captain

I'm naturally suspicous of overclocked CPUs. Do you have a way to monitor the temperature of your CPU?

Pro Member Chief Captain
Greekman72 Chief Captain

Im too but his problem seems to be from the beginning of the game so i dont know if it is an overclocking.No time to heat up so quick.I think...

Guest

CrashGordon wrote:

I'm naturally suspicous of overclocked CPUs. Do you have a way to monitor the temperature of your CPU?

It's not, for sure. I've just exited from Lineage II and the temp. is 54 C (129 F). As I said, I have no issues with other games Smile

Well, I really do not want to change my current drivers as these are optimized (aka modified), but I'll give a try to the latest NVIDIA drivers... As soon as I'll set them up, I'll post the situation here.

Pro Member Captain
WarHawk42 Captain

This sounds like you may not be getting a clean install. I had a problem with XP and a couple of other big programs (FS2004 & MSChampionship Golf). Do you have more than one CD-ROM drive? If so try installing it from the other drive. I found that I was having a problem getting a good install from both of my drives and had to install a new CD-ROM drive.

As a side note neither of my drives was that old.

Guest

WarHawk42 wrote:

This sounds like you may not be getting a clean install. I had a problem with XP and a couple of other big programs (FS2004 & MSChampionship Golf). Do you have more than one CD-ROM drive? If so try installing it from the other drive. I found that I was having a problem getting a good install from both of my drives and had to install a new CD-ROM drive.

As a side note neither of my drives was that old.

Did you expierence the same problems?

And yes, I have two optical drives. But how can it be, the installation says that everything went through and installation itself was successful. Rolling Eyes

Pro Member Chief Captain
Greekman72 Chief Captain

Tell us what you have try till now.

Pro Member Captain
WarHawk42 Captain

Anonymous wrote:

Did you expierence the same problems?

And yes, I have two optical drives. But how can it be, the installation says that everything went through and installation itself was successful. Rolling Eyes

Some of what you are describing is like problems I had. I fought getting XP running well for over a year, installing it several times to a reformatted hard drive to get a clean installation and still had problems. It would install and not indicate any problems, but they were there. The same with the other two programs I mentioned. They would install but then would crash or have errors in them. All of them run beautifully now since installing them from a good CD-ROM drive.

What you are describing is very similar to what I was going through. I can't say for sure that is your problem, but based on what I found it could be. Fortunately I had a spare CD-ROM drive I could drop in and it solved most of my problems. I also had a bad sound driver I had to update but that was a minor problem considering the other problems.

If you haven't tried installing the program from your other drive I would recommend trying it. It can't hurt.

Guest

WarHawk42 wrote:

If you haven't tried installing the program from your other drive I would recommend trying it. It can't hurt.

I'll try that, thanks Wink

Tom01 Guest

Ive got exactly the same problem. It comes up with the black screen quickly then quits. I did the microsoft Site info to open it straight into a flight but when i click select flight it freezes. I too have a Nvidia GeForce 6600 Gaphics Card. A pentium 4 3Ghz, definately clean, windows xp sp2 and the latest beta forceware drivers.

After reading this I beleive that this Graphics Card is faulty because all my other games work (rollercoaster tycoon 3, age of mythology etc.)

Pro Member Chief Captain
Greekman72 Chief Captain

I dont think that this is VGAs problem.Drivers problem maybe,but not VGAs.My opinion is that this kind of problem has to do with bad installation or unclean registries or an add on which spam FS(although i havent meet any)or some other spams,or a systems memory problem.I have used till today three different Nvidia VGAs(4200,5700,7800)and never have had a problem.

I have seen a lot of systems with monsterous proccessors,great VGAs and enough of memory,which although face up some strange problems like yours.All the owners sais the same thing....''my pc is great and clean'' etc etc.When we clean it(registries,spams,some programms or utilities that runs in start up and forever without no meaning)defragment it,get rid of uselles partitions,or in worst case we format them all these problems get dissapear.

A system needs care in order to work properly and you have to know that you must have some routines to keep it clear that you must repeat them frequently.Every programm we install,every download we make,every game we run put load to our system performance and also adds a lot of things that we can figure out that they excist in our system and maybe they are the trouble makers.

Friendly Wink

Guest

I do have a free 17GB+disc space in my computer but this error is really annoying:

Pro Member Chief Captain
RadarMan Chief Captain

See if these help.

http://support.microsoft.com/kb/892610/en-us

http://support.microsoft.com/kb/837869/en-us

I see how many icons you have on your desktop, they and all the programs running in the background use up memory also.

Radar

Guest

Uhh... it happens in the CD1 everytime on the "lear45_D.bmp" or i don't know...

Pro Member Chief Captain
RadarMan Chief Captain

Anonymous wrote:

Uhh... it happens in the CD1 everytime on the "lear45_D.bmp" or i don't know...

I just reread the entire post and your problem has nothing to do with the rest of this thread, very confusing.

Did you try everything suggested in the two links that I posted from MS.

Radar

Guest

Hmmm... but i really really need help on it... Crying or Very sad

Pro Member Chief Captain
RadarMan Chief Captain

Anonymous wrote:

Hmmm... but i really really need help on it... Crying or Very sad

No one can help if they don't know what you've already tried.

Radar

Guest

I tried re installing in different things like compact or complete but still it stops at the "Lear45_d.bmp" Crying or Very sad

Pro Member Chief Captain
CRJCapt Chief Captain

Fully (manually) uninstall Flight Simulator: https://flyawaysimulation.com/news/3805/
1. Use a CD-ROM or DVD-ROM drive. Avoid rewritable drives for installation.

2. Make sure your not using Internet Explorer 7 beta on your computer.

3. Disable anti-virus program.

4. Shut down unnecessary programs running in the background.

Install Flight Simulator (full/complete) installation.
Smile

Guest

Hmm.... the error only goes out in the CD1 it has a desame kind of problem with: https://forum.flyawaysimulation.com/forum/topic/2623/fs2004-installation-problems/ only my problem is on "Lear45_D.bmp"

All times are GMT Page 1 of 1

Related Questions