SearchSearch 

FS2004 crashes

RAH2006 Guest

Everytime a select the "Create a Flight" option or I try to change the airplane, my simulator shows a black frame instead the airplane and crashes. Can anyone help me to find out what's going on.
My FS2004 worked fine for two years and now it works fine just for 2 or 3 times after reinstalling it.

15 Responses

Pro Member Chief Captain
RadarMan Chief Captain

Clean out and reinstall your video drivers, they sound as if they are corrupted.
If you have an older video card use older drivers, usually the newest drives won't work well on older cards.

If that doesn't work tell us your system specs so we can try to help.

Radar

RAH2006 Guest

Thaanks for trying to help me.
I've tried with several NVidia drivers from 77.72 to 84.21.

My specs are:

PIII 1.2Ghz
512Mb RAM
GPU: Geforce 2 MX400

If I select a saved flight it works fine for every plane and/or scenery and i fly for hours. I just can't change the plane or create new flights.

Th only way to temporary solve the problem is reinstalling the FS2004 from the beginning. So I could create 1 or 2 flights before crashing. After that the problems starts again and nothing that i know can solve it. I already try to install just default airplane/scenery, tried to create a new FS9.cfg, but neither of this options solved the problem.

Pro Member Chief Captain
RadarMan Chief Captain

That is very strange. If it crashed every time I would say overheating but if you can run it for an hour it can't be that or programs running in the background (unless you had 98ME).
With that old a card I would use the oldest drivers I could find, it only has 64mb.
I had a 64 mb card with the sim once and I couldn't fly anything but GMAX aircraft everything else would crash Windows not just my sim.
I cured it with a better card, a Radeon 9800 Pro 128mb DDR (AGP).

I honestly don't know what to tell you, more members will be on line in a few hours, it pretty quiet at this time of night.

Radar

Pro Member Chief Captain
Greekman72 Chief Captain

RadarMan has already gave you some right instructions.

If im allowed i would like to add that if i was you i will do the following steps.

1.Unistall FS
2.Clean up the registries from FS records.(Start/Run/ type Regedit Edit/Find type Flight and hit Find.Delete everything founded.Then hit next till the finds stops.
3.Run a disk clean-up.
4.Run a disk defragment.
5.Run some spy-ware program like spy bot ➡

http://www.download.com/3120-20_4-0.html?tag=srch&nid=1&qt=spybot&tg=dl-20&search.x=23&search.y=10
6.Unistall your Graphics Card and install it with the drivers you buy it(I suppose you kept this CD)
7.Turn off your system.
8.Open case.
9.Clean the dust(very carefully with a vacuum)Clean the fans and the heatsink of CPU as better as you can.Dont practice to remove them if you have never do this again.
10.Start
11.Install FS.
12.Install a start-up manager like FSAutoStart(first in the following list)

https://forum.flyawaysimulation.com/forum/topic/12580/some-usefull-utilites/

..and run it in order to close-disable all the unnecessary programs that probably running on background.

13.Go to FS settings and follow the instructions from the following guide

https://forum.flyawaysimulation.com/forum/topic/12375/2-minute-guide-to-maximase-your-flight-sim-experience/

-Dont push your system too much by increasing graphics setting.The results are the opposite.

If you can effort it try to upgrade your Graphics card.Another stick of 512mb of RAM should helps but not before you get a new GFX.

Let us know if we were helpful to you and feel free for any further questions. 😉

RAH2006 Guest

I've done everything Radarman told me to do and guess what ????
It works fine for 3 times and then the problem starts again.

😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞 😞

The only thing that crashes is the frame with the rolling airplane in Select Aircraft and in Create Flight menu. Is there a way to disable this frame ???

RAH2006 Guest

Here is the example of what it's look like.....

I Radar fixed the screenshot.

Pro Member Chief Captain
RadarMan Chief Captain

I'm not very familiar with Nvida cards but I remember something about that type of problem and you have to get a driver with the number 74.??? or lower to remedy that problem.

Radar

RAH2006 Guest

I've tried 5 diferent drivers and all present the same problems. I think that's a register or configuration problem but this one is really hard. Is there a way to disable aircraft displey in this menus ????

skint Guest

Help,help,help,i am having a similar problem to guest April 11.When atc asks me to decend and i press gps icon fs9 crashes to desktop also if iwant to change aircraft or flightplan in flight same thing happens,then i get that irritating box fs9 has encountered a problem send\don,t send error report to microsoft.I am running p4 processor with a nvidia geforce 6800 le graphics card.

Pro Member Chief Captain
RadarMan Chief Captain

skint wrote:

Help,help,help,i am having a similar problem to guest April 11.When atc asks me to decend and i press gps icon fs9 crashes to desktop also if iwant to change aircraft or flightplan in flight same thing happens,then i get that irritating box fs9 has encountered a problem send\don,t send error report to microsoft.I am running p4 processor with a nvidia geforce 6800 le graphics card.

Did you follow all of the suggestions given above.
If so, and it still doesn't work what are your system specs.

Radar

skint Guest

Thanks to RadarMan and Greekman72 for your help and information,i have followed your recommendations and am now in the process of re-installing FS9 and replacing all my add-ons. I will let you know if it works,once again thanks for all your help.

Pro Member Chief Captain
liam (Liono) Chief Captain

When you re-install FS please follow this instructions

Install FS then load it up
Install the patch FS9 update then load the sim up
Then this is really important. When you go to install your payware/freeware add-ons,

Please install them ONE AT A TIME

After each install load up the sim.

Also on a side note try not to use the crack as it corrupts the registry.

Thanks for taking this time read this post, and best of luck

Regards,

Liono

Pro Member Chief Captain
Tailhook Chief Captain

Liono wrote:

When you re-install FS please follow this instructions

Install FS then load it up
Install the patch FS9 update then load the sim up
Then this is really important. When you go to install your payware/freeware add-ons,

Please install them ONE AT A TIME

After each install load up the sim.

Also on a side note try not to use the crack as it corrupts the registry.

Thanks for taking this time read this post, and best of luck

Regards,

Liono

Sound advice Liono and really the only way to do it.

The notion that the crack corrupts the registry though has me puzzled and frankly terrified.

If it wasn't for the crack, I'd be going through several drives and disk 4s each month.

Imagine you spend several hours installing a/c, textures, sounds etc. Each time I make the slightest change, even if it's just editing a .cfg I start up FS to check if everything works fine - then I exit FS and go on to the next bit and continue in the same manner.

Some days I might start and exit FS close to a hundred times. No kidding. Can you imagine what effect this would have on my drive and disk without using the crack?

Not trying to argue your point at all, but I would like to understand how the crack corrupts the registry, whether there is a workaround and even the possibility that not all cracks work the same way.

I have got 2 cracks for fs9.1 from different authors. This is no mistake - I'm not confusing fs9 with fs9.1. Dont Know

Give me some good news, please.

Skint Guest

Don,t know if this post was for me but thanks to Liono for your advice,i always load add-ons one at a time just to make sure i get things right. I note your location as 10 miles from Luton Airport, I am about 20 miles from Cardiff Airport. No need to thank us novices for taking time to read your posts its nice to know there are people out there willing to help.

Regards. Skint.

P.S. Have,nt got a clue what the crack is.

Skint Guest

Thanks to RadarMan, Greekman72 and Liono for all your help it seems to be working ok now, touch wood.

All times are GMT Page 1 of 1

Related Questions